PDA

View Full Version : Bad voltage regulator?



Scott
10-23-2005, 08:19 PM
I'm wondering if flickering headlights with accompanying flicks on the ammeter usually indicate a bad voltage regulator. My '64 Daytona had those symptoms and my '66 Cruiser does too - and fairly badly to start off with.

I've never replaced these things. It looks easy enough, but I just wondered if it's a common thing to go bad. Maybe they just get really dirty and corroded after 40+ years.

JDP
10-23-2005, 10:50 PM
It may well be the regulator. If so, replace it with a solid state version used on late 60's Chrysler products.

Studebaker On The Net http://stude.com
64 R2 4 speed Challenger (Plain Wrapper)
63 R2 4 speed GT Hawk

Scott
10-24-2005, 04:19 PM
JDP, that sounds like a good idea. I have been told, though, that the Chrysler units have 2 wires coming out of them, whereas the regular ones Studebaker used have 4 wires. How is the two wire version supposed to replace the older 4 wire version?

chrysleritis
10-24-2005, 05:40 PM
Could very well be the voltage regulator -- they go bad when the points wear
or get dirty and get out of adjustment. The original ones can be repaired, but it's
not worth the trouble to fiddle them into correct behavior. An original unit would
almost certainly be shot by now.

Note that what you describe -- flickering headlights and ammeter -- could also be a
short somewhere in the harness. That is a very likely scenario, too. Does the
ammeter go to high current draw or to low current draw when it flickers? Could be
a short to ground or a flaky connection in the headlight circuit.

It's a nuisance tracking down electrical problems.

Alan
10-24-2005, 06:25 PM
First thing to look for is a bad ground. On the Chrysler the 2 wires go to the regulator, the regulator grounds one wire so current flows through the field so that it charges.

oldvinyl
10-24-2005, 07:50 PM
Check the requirements of your headlights aswell, and like Alan said check the ground circuit real good. In the past I have had to install a relay cicuit breaker of higher value, and this solved the problem. You may have an alternator thats on the way out, or bad battery. Load test the charging system first, then go from there. Sometimes circuits get messed with by owners and I have found overload issues quite often due to bad sterio installs and other accessories. Its a good Idea to check to make sure that someone has not butchered your fuse panel or spliced into places that could cause problems. Ground circuits seem to take real abuse at times. The chrysler charging method is a good recomendation, I have used it in alot of my engine swaps due to its simplicity, and quite reliable., Tom.

Scott
10-24-2005, 08:22 PM
Well, of course everything in this car is suspect, but I think the wiring is probably OK. The ammeter never gets much below the center line at any time when the flickering occurs and it is very regular - say about a flicker every half second. If it was a short, even an intermittent one, I would expect less regularity.

Alan
10-24-2005, 09:05 PM
You realy didn't say as to weather you had a electronic regulator or a relay type regulator but it sounds like a bad ground the electronic regulator grounds through the case and the relay type does too. The fluttering could be the relay kicking in and out because of bad ground.

oldvinyl
10-24-2005, 09:25 PM
Right on Alan, Tom.

Scott
10-24-2005, 10:00 PM
Hmmm... OK. I hate checking for grounds, but a guy's gotta do what a guy's gotta do.

It is the old mechanical relay type. If I put a new solid state one in and the ground is not good somewhere else could I damage the new unit?

JDP
10-24-2005, 10:21 PM
4 wire ?, is it a Avanti ? If so, Dave T Bow sells a solid state version.

Studebaker On The Net http://stude.com
64 GT Hawk
64 R2 4 speed Challenger
63 R2 4 speed GT Hawk
53 Street rod

oldvinyl
10-25-2005, 01:50 AM
Yes you can damage it. Motorolla does not like to dead end. Tom.