Announcement

Collapse
No announcement yet.

Carter RBS issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fuel System: Carter RBS issues

    I recently installed an overhauled Carter RBS from CarbX in my 63 Lark 6 cyl. I now have an intermittent problem where the idle will rev up really high at a stop (maybe 1500-2000 rpm). By intermittent, I mean every 3rd stop or so when at idle. Starts, runs, drives great other than that. I've been under the hood tinkering with throttle linkage and idle adjustments to no avail. Additionally the engine has started dieseling when I turn it off because of the fuel being dumped into the carb, which you can smell. I'm frustrated, any help would be appreciated.

  • #2
    It sounds as if there is something loose either in the throttle linkage but more likely the throttle plats itself. Dieseling was an issue many years ago as carbs were designed with a shut off of sorts that either allowed the plate to close more completely or a solenoid was installed in the idle fuel circuit closing when the ignition was turned off. It sounds like if you were to be real careful with a physical inspection you might find an issue somewhere in that arena. I worked with a German manufacture during the 70's and it seems like in 72 there started the idle fuel solenoids as a resolution for a after run condition.

    Comment


    • #3
      Not sure this is your problem, but have you checked your motor and trans mounts? Forward-backward movement of the engine-trans will cause drastic idle changes due to linkage movement. I would also check the lever arm to butterfly shaft connection for wear or looseness, if I remember correctly the lever is just "swaged" in place and can loosen after 50 plus years of motion. If that isn't the problem perhaps the butterfly screws are loose, or worst case the shaft bearing surface going through the carb throttle plate is badly worn oblong so the butterfly isn't hitting the throat at the same place all the time. Dieseling is a little harder to diagnose and can be fuel dependent, excess combustion chamber deposits, coolant flow related--too high an idle, if it's an automatic--kicker or dashpot adjusted wrong, floats too high, bad inlet needle. Give us a few more particulars about the car, the type of gas you are using.

      Comment


      • #4
        Now that you mention it, I've noticed that the idle is much lower when on a hill facing up and it tends to be very high while stopped on a hill facing down. This would go with your theory of motor trans mounts being broken or loose. I'll check and advise. Thanks.

        Comment


        • #5
          Hi Check your float level The wifes Champ was acting similar , I read the shop manual and not the sheet that came with the rebuild kit , You measure the float level at the knubs at the end of the float , Hope this helps , Ed

          Comment


          • #6
            Now comes the part you do not want to hear after maybe spending Time and definitely Money to rebuild a Carter RBS.

            They are probably the WORST Carb. Studebaker ever purchased for any model, ever!
            Most owners of '63 and '64 Larks and Lark Types have moved up to the much better Carter Model "AS" 1 Brl. as used on '62 Larks.

            These RBS Carbs. are very simple, cheap Rambler Carbs. often rumored to be a Series/Model rejected by AMC and were a "Good Deal"!

            Try "tweaking it", but if all else fails look for a Model "AS".
            Last edited by StudeRich; 07-08-2016, 03:58 PM.
            StudeRich
            Second Generation Stude Driver,
            Proud '54 Starliner Owner

            Comment


            • #7
              Mine performs well but I spent a lot of time onto it. Unless it's been overhauled with the shop manual at hand, I would verify all the settings again. I can send you the data if you need. If the choke valve or its command is not binding somewhere or out of adjustement, the problem should be in the throttle command. I noticed that, even with a new spring, mine does not return always return to the fully closed position at idle. Also, be sure that the PCV valve is not clogged or stuck as this would affect the idle. About the motor mounts, be aware that the original ones had one thread longer than the other.
              Best of luck.
              sigpic

              Comment


              • #8
                Check for soggy mounts first thing,unique linkage set up is sensitive to fore and aft movement. and i agree the RBS is next to nothing but the AS in usable condition is getting scarce. solid mounts and save the RBS. Luck Doofus

                Comment


                • #9
                  Back at it after having a baby and shelving this project. I checked motor and trains mounts...they're solid. Discovered damaged shocks though, which is a bummer because they were only a couple years old. (The top posts stripped out). Replaced them and it's actually improved the problem, but not completely. I guess I'll take it apart and check the float setting. I have to say, I've been disappointed with CarbX and would not recommend anyone using them. They advertise sending you a completely tuned and ready to go carb...I don't think that's the case. Also it took me 5 phone calls to get my core deposit back. Now I wish I had my original carb...

                  hopefully adjusting the float height solves this problem. I'll report back. Thanks for the advise.

                  Comment


                  • #10
                    It was the float setting. It was off by 3/16". I'll reiterate that my experience with CarbX has been dissapointing. I. Would not recommend using them.

                    Comment


                    • #11
                      Originally posted by Surfpilot View Post
                      It was the float setting. It was off by 3/16". I'll reiterate that my experience with CarbX has been dissapointing. I. Would not recommend using them.
                      Good to hear that it is running better! So for the Record, the Float Level was TOO High correct?
                      StudeRich
                      Second Generation Stude Driver,
                      Proud '54 Starliner Owner

                      Comment


                      • #12
                        The float was set at 21/32". So depending on how you look at it... Yes, too high

                        Comment


                        • #13
                          How did you measure it, inverted with the gasket in place and measured to what spot on the float?

                          Comment


                          • #14
                            Yes and to the bump. As per shop manual

                            Comment


                            • #15
                              Should be perfect then. Enjoy it

                              Comment

                              Working...
                              X