No announcement yet.

Overdrive on my 41 Commander

  • Filter
  • Time
  • Show
Clear All
new posts

  • Transmission / Overdrive: Overdrive on my 41 Commander

    I had a garage put in a new clutch a few months ago, I didn't realise they weren't very good, and since then the overdrive hasn't worked. I have checked the cable and tightened it a bit, as the knob almost came out of it's housing completely. This has made no difference except I could hear the gearing trying to engage. So pushed knob back in and came home. Looked at my manual and changed the fuse on the Trans relay, although I thought it was a strange set up with the fuse being on the outside and no wire coming from the top. But it worked perfectly for the previous 10 years as I pushed the clutch in and had a reassuring "clunk" before having that small boost of speed. Anyone any ideas? I hope it is not the solenoid, but if it is where can I get one, and more importantly does the gearbox have to come out to fit it?
    Help would be appreciated.

  • #2
    Google it.
    You will find many articles on how to trouble shoot etc.
    The most important check is by running a wire directly to the solenoid from a fused
    additional temporary switch and see if the problem is electrical or mechanical.
    Do not forget that the solenoid is not powerful enough to pull into overdrive unless you take the torque off the transmission by taking you foot of the accelerator.
    This is done electrically in the original setup.
    The solenoids rarely go bad and new ones are readily available.
    Robert Kapteyn
    Last edited by rkapteyn; 06-14-2015, 05:56 AM.


    • #3
      Thank you, will do this in the week


      • #4
        If the overdrive worked fine before the shop installed the clutch, then most likely you only need to adjust the overdrive cable or install the wires correctly.
        Start by makeing sure the O/D lever moves all the way to the rear when the cable is pushed in. Then fine the overdrive wiring schematic for your car and make sure each wire to the governor and solenoid is the correct one. The problem here could be the color coding on the old cloth wires is long gone.