Announcement

Collapse
No announcement yet.

Brake Light Troubleshooting - 1957 Silver Hawk

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • StudeRich
    replied
    Either the power brake booster having residual pressure, or a swelled hose to it, or if it has a hill holder it's holding press. because it's out of adjustment.

    StudeRich
    Studebakers Northwest
    Ferndale, WA

    Leave a comment:


  • MikeW
    replied
    Mark,
    Does your car have a Hydrovac PB Booster on the inner fender?


    Mike
    www.packardhawk.com

    Leave a comment:


  • bondobilly
    replied
    I forgot. Last night I got in a cpoy of Kantor Auto Parts new catalog. Under brake light switches, they list a Studebaker brake light switch at $27.00 plus shipping. Twenty-Seven dollars.

    Leave a comment:


  • bondobilly
    replied
    You have a wiring issue. That is indicated by the turn signals affecting the brake switch. There are a few ways to check. Remove the wires from the tailights, brake lights and from the upfront directionals. With service manula in hand look at each wire, and find out which wire terminates where. You will notice that on the diagram there are colors, white with brown stripe, green with red strip etc. Locate each wire and make sure that they all go where they are suposed to be.

    Since it is a 57 Hawk, was any of the front end re-painted? If so, one or both of the "parking lights" might not be grounded properly causing this situation. Sounds off the wall but in some cases a non grounded parking light will cause your problem.

    Leave a comment:


  • 41 Frank
    replied
    Remove the switch and do a continuity test, if power goes through the switch the contacts are stuck closed and you will need a new switch again.

    Leave a comment:


  • Brake Light Troubleshooting - 1957 Silver Hawk

    I'm still trying to troubleshoot a brake light problem - brake lights are always on. I've replaced the hydraulic switch - no help. I've backed off the mastercylinder plunger - no help. I can't think of what else to do.
    The appropriate brake light does cancel when I use the turn signal. The brake lights stay on with my foot off the brake pedal and with the ignition off (key out of car). I have to disconnect on of the hydraulic switch wires between drives or my battery will go dead.
    I seem to think its the hydraulic switch. I just put a new one on (from Steven Allen's). Any chance its stuck?
    Any chance my master cylinder is still applying pressure to the switch when my foot's off the brake?
    Any help will be greatly appreciated.
    Thanks, Mark

    Mark Rogers
Working...
X