Announcement

Collapse
No announcement yet.

Avanti right front signal lamp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Electrical: Avanti right front signal lamp

    Can see to get the right front signal lamp to blink. The rear one works. The parking lamps work. I changed the socket and harness on the signal lamp. Any ideas?
    jerry defilippi

  • #2
    Originally posted by jerry1 View Post
    Can see to get the right front signal lamp to blink. The rear one works. The parking lamps work. I changed the socket and harness on the signal lamp. Any ideas?
    Check for power to the contacts with a VOM or test light, if none follow the power back until you find the break, If there's power check the bulb and also be sure the spring holds the contacts against the bulb base. Also look for corrosion on the contacts or bulb and clean necessary. All that done, check the ground.

    Bob

    Comment


    • #3
      I had that issue a couple of times with the left front turn signal and parking light. Issue was a ground both times.
      sigpic[SIGPIC]

      Comment


      • #4
        I had an issue w/NORS parking light housings. There was a break in the contact/ground between the socket & housing in my '81 Avanti rebuild.
        Rob in PA.

        Comment


        • #5
          Check the wire for the right front turn to see if it is properly/tightly connected at the Steering Column plug.
          StudeRich
          Second Generation Stude Driver,
          Proud '54 Starliner Owner

          Comment


          • #6
            Thank you all. I was a broken wire to steering column.
            jerry defilippi

            Comment

            Working...
            X