Announcement

Collapse

Get more Tips, Specs and Technical Data!

Did you know... this Forum is a service of the Studebaker Drivers Club? For more technical tips, specifications, history and tech data, visit the Tech Tips page at the SDC Homepage: www.studebakerdriversclub.com/tips.asp
See more
See less

Carter AFB R1 Start Fuel Lack

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • StudeRich
    replied
    Yeah, that really IS lame [xx(], because ironically Carter has no intention of ever selling any repair parts for their fuel pumps. That is just typical of what happens when small companies get gobbled up by giant conglomerate Corps. they no longer care!



    quote:Originally posted by sbca96

    Talk about lame.
    StudeRich
    Studebakers Northwest
    Ferndale, WA

    Leave a comment:


  • sbca96
    replied
    From what I understand from information I collected during my quest
    to get the correct upper seal - Carter owns the copyright on the metal
    part of the seal, and so SI and others can not sell that part. They
    can only sell the rubber part of it, and that gets destroyed by the
    spring/washer they are forced to use. Talk about lame.

    Here is the correct seal prior to install :





    Here is the seal you get in the kit (mine was torn when I got it) :



    Tom

    quote:Originally posted by StudeRich
    And, they are the same ones Tom got from S.I. There is only one manufacturer of the kits, AND it sure is not Carter!

    Leave a comment:


  • StudeRich
    replied
    quote:Originally posted by Laemmle

    dave Thibeault has the correct kits
    And, they are the same ones Tom got from S.I. There is only one manufacturer of the kits, AND it sure is not Carter!

    StudeRich
    Studebakers Northwest
    Ferndale, WA

    Leave a comment:


  • Laemmle
    replied
    dave Thibeault has the correct kits


    quote:Originally posted by ivorydan

    Tim and Dan: You know it very well could be the two check valves. I replaced the little rubber washers around them when I rebuilt the pump (had to press out the valves, replace the washers and press the valves back in) but didn't thik about replacing the valves themselves. It's an original Carter R1 pump. Where can I get the valves? Thanks.

    Leave a comment:


  • sbca96
    replied
    The valves dont even come in the kit anymore, they send you rivots.
    The rubber part you replaced IS the "valve". The mushroom is just a
    holder for the rubber disc.

    My "how to" tech article .. buried on page 30.[B)]

    http://www.studebakerdriversclub.com...?TOPIC_ID=5982

    Tom

    quote:Originally posted by ivorydan

    Tim and Dan: You know it very well could be the two check valves. I replaced the little rubber washers around them when I rebuilt the pump ..... Where can I get the valves? Thanks.
    '63 Avanti, zinc plated drilled & slotted 03 Mustang Cobra 13" front disc/98 GT rear brakes, 03 Cobra 17" wheels, GM alt, 97 Z28 leather seats, soon: 97 Z28 T-56 6-spd, Ported heads w/SST full flow valves, 'R3' 276 cam, Edelbrock AFB Carb, GM HEI distributor, 8.8mm plug wires

    Leave a comment:


  • ROADRACELARK
    replied
    Dan,
    The last ones I got, the valve, spring, and the rubber seal, came from one of the major rebuilders. (you know, the back door kind) Other than that kind of source, I'm not sure. Those don't come in pump rebuild kits for some reason [B)]. Mabe some one else will chime in with help.

    Dan Miller
    Atlanta, GA

    [img=left]http://static.flickr.com/57/228744729_7aff5f0118_m.jpg[/img=left]
    Road Racers turn left AND right.

    Leave a comment:


  • ivorydan
    replied
    Tim and Dan: You know it very well could be the two check valves. I replaced the little rubber washers around them when I rebuilt the pump (had to press out the valves, replace the washers and press the valves back in) but didn't thik about replacing the valves themselves. It's an original Carter R1 pump. Where can I get the valves? Thanks.

    Leave a comment:


  • Dick Steinkamp
    replied
    ...also, after several rebuilds, the casting on the carb float bowl becomes more porous and the fuel can evaporate from the bowl after a couple of days.


    Leave a comment:


  • ROADRACELARK
    replied
    What shape is the fuel pump in? If it's not close to new, it could have weak or faulty check valves that are allowing the fuel to be siphoned back to the tank. If it's the original Carter pump, those were prone to do that. Also check the rubber line back at the tank. The original line had the wire spring clamps. Use new fuel line with the worm drive clamps. Any rusty metal line could have a pin hole in it as well. Hope this helps.

    Dan Miller
    Atlanta, GA

    [img=left]http://static.flickr.com/57/228744729_7aff5f0118_m.jpg[/img=left]
    Road Racers turn left AND right.

    Leave a comment:


  • GTtim
    replied
    When I park my Hawk warm and open the hood I will sometimes see the fuel bowl drain slowly and then as if by magic as the car cools it will siphon the gas back in. After about 4 days the bowl will be empty. If yours is empty before then, I'd say the little valves in the fuel pump need replacing.

    Tim K.
    '64 R2 GT Hawk

    Leave a comment:


  • Karl
    replied
    remove the air cleaner.Check to see that your accelerator pump is working.Because you can dribble a little gas and it starts.that would appear to be the problem.

    63 Twin Supercharged Avanti
    64 Avanti R3w/NOS
    88LSC Avanti 350 Supercharged w/NOS

    Leave a comment:


  • ivorydan
    started a topic Carter AFB R1 Start Fuel Lack

    Carter AFB R1 Start Fuel Lack

    When the engine's cold, I squirt 3 or 4 shots of gasoline into the front barrels of the carb from a small oil can. I then start it and it fires right up and runs fine thereafter. If I don't do this it just grinds away and never fires. I also see the glass fuel filter bowl that was full last night when I ran it is empty this morning. When the car used to start more easily, the fuel filter bowl would stay full for weeks between starts. I had the carb rebuilt recently. I recall the same problem before I had it rebuilt. I push the accelerator one time to the floor and release before trying to start. The fuel pump has been rebuilt. Both the gas and return lines are new. The gas tank was boiled and coated inside. There's probably some simple answer?
Working...
X