Announcement

Collapse
No announcement yet.

starter solenoid

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Electrical: starter solenoid

    I'm restoring a 57 pickup with a 259 v/8. New starter solenoid I installed doesn't work. I connected it with all new wiring following the electrical diagram in the old Stude manual. I hear a faint click when I turn the switch to start not like I think a solenoid should sound . No power to the load terminal.The other small terminal which goes to the coil shows partial voltage. I feel stupid. Does anyone have a Echlin hookup diagram?

  • #2
    Check the line voltage first, sounds like you have a bad solenoid. Also check the wire to the ignition switch.

    Comment


    • #3
      The small terminal marked S on the solenoid gets connected to the start position on the ignition switch and the terminal marked I goes to the + or battery terminal of the ignition coil. Like jallen states, be sure that you have 12 volts at the S terminal of the solenoid when you turn the ignition switch to the start position or the solenoid won't energize. If you have 12 volts, the solenoid is defective, if not, start checking for loose or bad connections between the battery, ammeter, ignition switch and solenoid. Bud

      Comment


      • #4
        As an added note, I had a problem starting my 63 Avanti recently, it was doing the same thing as your truck and it turned out that the ignition switch had worn out and wouldn't make a connection to the solenoid. Bud

        Comment


        • #5
          This may not apply to your pickup, but I had a similar problem this summer with my Avanti R-2 with the PowerShift AT. It would not turn over even though the battery tested OK. Occasionally I would get a slight click from the solenoid. I replaced the solenoid without testing anything first. It did not fix the problem. So I starting testing. The ignition switch was OK but I was not getting 12 volts @ the solenoid. So I checked the wiring diagram and it confirmed that for juice to get to the solenoid it had to go through the safety switch (AKA starter cut-out switch) on the shifter underneath the console. I discovered 2 things there, either one or both of which could have been the problem. The two wire connector to the safety switch was very corroded, so I cleaned it up. In addition the safety switch was so rusty and corroded that the arm on it would hardly move. I had been noticing for several months that even with the leverage of the floor shift handle it was getting harder and harder to go from Park to any of the gears and back. So I replaced the saftey switch and cleaned up the connectors. That solved the problem.

          None of this is surprising of you stop to think about it. The switch and the connectors are exposed to the elements when driving and to any moisture coming up from the concrete floor of my shop. It had been nearly 30 years since those pieces were taken apart and cleaned up.
          Stan Gundry
          www.AvantiPublishing.com

          Comment


          • #6
            Thanks for the suggestions, I appreciate the help. I think I found the problem. Turns out after bench testing the solenoid it has to be mounted vertically, that is the cap end up or the solenoid won't pick. I mounted it like the old one was by the same bolt holes in the firewall & that one worked apparently ever since '57 but the new one wouldn't. Probably made in China. The small terminals aren't marked with the + or - marks . Maybe I'll find a nos solenoid.

            Comment

            Working...
            X