Announcement

Collapse
No announcement yet.

Total and complete idiot (me) strikes again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Electrical: Total and complete idiot (me) strikes again

    Before you guys laugh uncontrollably at me remember, i am not trying to restore my 62 hawk. I am just trying to get it drivable enough to get it to someone with skills. OK, yesterday I woke up with a horrendous toothache.I called my dentist and got an appt. at 2:00 for a root canal, Oh Boy. Instead of laying around in agony I thought fixing just one thing on the hawk would occupy my brain. I decided flush and fill the radiator was about my speed. She seemed a little hot on our maiden 12 mile journey. After draining the rad. adding the prestone flush and water I went to start her up.UGG no battery since i left the key on after my fruitless attempt ,yesterday to fix the temp guage.I hooked up the battery charger +to+ - to - and started to worry if the flush stuff was eating my radiator.After not enough time I tried I got the ole Woo Woo click click clik.Got impatient and tried to charge and start again with the same results.By this time i was worried about the flush in the radiator,so i drained and rinsed throughly.Now it was time fo rthe dental torture,so I disconnected the battey cables and hooked up the charger to charge overnight.Heres the rub when I reconnected the battery cables(the correct way )the engine turned over no key no switch just connecting the cables.My tooth hurts like hell right now, but it would hurt more to harm the Hawk. Someone please tell that I didn't screw something big up.

  • #2
    No, you didn't hurt a thing. It's probably a worn ignition switch that caused it. They can wear and stick in the 'Start' position even with the key out. Or, could be a stuck solenoid. In any case, the fix won't be a big deal.

    Also- I know you're being fecetious, but no one thinks you're an 'idiot' or a problem for asking questions. That's the main reason for this forum! Everyone has different knowledge levels. No crime in that.

    Feel free to ask away
    Last edited by Bob Andrews; 09-13-2011, 04:22 PM.
    Proud NON-CASO

    I do not prize the word "cheap." It is not a badge of honor...it is a symbol of despair. ~ William McKinley

    If it is decreed that I should go down, then let me go down linked with the truth - let me die in the advocacy of what is just and right.- Lincoln

    GOD BLESS AMERICA

    Ephesians 6:10-17
    Romans 15:13
    Deuteronomy 31:6
    Proverbs 28:1

    Illegitimi non carborundum

    Comment


    • #3
      Sounds like the starter relay (solenoid) is stuck in the energized position. Give it a good wrap with the handle of you ratchet and that should free it. The starter relay is the little tubular shaped doodad thing that the big battery cable goes to. Yours might be built inside the starter. Oh yea, put water in the radiator! All the cleaners for the radiator are fairly lame so leaving it in too long is not a problem, heck might good for it...
      1948 M15A-20 Flatbed Truck Rescue
      See rescue progress here on this blog:
      http://studem15a-20.blogspot.com/

      Comment


      • #4
        Probably just stuck solonoid. David

        Comment


        • #5
          Thanks

          Wheeew what a relief. Studebaker folks are so cool, It's like living next door to Ward June Wally and The Bev.

          Comment

          Working...
          X