Announcement

Collapse

Get more Tips, Specs and Technical Data!

Did you know... this Forum is a service of the Studebaker Drivers Club? For more technical tips, specifications, history and tech data, visit the Tech Tips page at the SDC Homepage: www.studebakerdriversclub.com/tips.asp
See more
See less

transmission/accelerator linkage

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • transmission/accelerator linkage

    I'm having a problem with my '62 sedan. On a fast start the car will stick in full throttle.[:0]

    The conditions that precede problem:

    1) I manually downshift the car to 1st.

    2) The throttle is applied 1/2 way (anymore scares me, this car can go).

    3) The accelerator drops to the floor of it's own accord. Tires spin engine roars and I have no controll of the motor at all.

    I mean, don't get me wrong, it's fun to fly off in a cloud of smoke and dust. Is it too much to ask for a little control?[:I]

    After a few hundred feet the throttle releases and the engine drops to idle. There is a bar attached to the throttle control rod that goes back to the tranny. Is this the problem? Is something in the transmission malfunctioning?

    Any suggestions?

    Lotsa Larks!
    K.I.S.S. Keep It Simple Studebaker!
    Ron Smith

  • #2
    Your left front motor mount is broken. Heck, they're probably all shot.

    Dwain G.

    Comment


    • #3
      What he said. After breaking two on my own '62 I made my own, I took two busted ones and drilled a hole through the biscuits, cut one of the biscuits small enough to fit above the bracket that goes to the block, and bolted it all together with a long through bolt. This way no matter what it's always loaded in compression. I had to pass the bolt through from below so I used a Nylock to prevent it from vibrating loose and falling into the steering linkage (that would be bad.)

      It is kind of unsettling to be approaching a stop sign at WOT. Fortunately hitting the clutch (mine was a 4-speed) unloaded the engine and that let go of the throttle.

      nate

      --
      55 Commander Starlight
      62 Daytona hardtop
      http://home.comcast.net/~njnagel
      --
      55 Commander Starlight
      http://members.cox.net/njnagel

      Comment


      • #4
        quote:Originally posted by N8N

        What he said. After breaking two on my own '62 I made my own, I took two busted ones and drilled a hole through the biscuits, cut one of the biscuits small enough to fit above the bracket that goes to the block, and bolted it all together with a long through bolt. This way no matter what it's always loaded in compression. I had to pass the bolt through from below so I used a Nylock to prevent it from vibrating loose and falling into the steering linkage (that would be bad.)
        Very good advice above. I did the same thing with my 60 Hawk years
        ago when I broke mount after mount. I sware some would break the same
        day!! I did the same thing, thru hole, long bolt - I double nutted.
        I only needed to do that with the drivers side mount. I need to put
        that on the Avanti, I can SEE that the engine is shifted in the bay!

        If the engine moved, then the rod that goes through the floor to the
        pedal can rub on the thru hole and hang up.

        Tom

        1963 Studebaker Avanti, 102,000, custom made brake brackets to mount 1998 Mustang GT 4 wheel disc brakes (soon to get 13" Cobra front brakes, 2003 Mustang Cobra 17" wheels, GM altenator, will be getting : 97 Camaro Z28 tan leather seats, 97 Camaro Z28 T-56 6-speed trans, Ported 'R3' style Avanti heads with stainless full flow valves, 'R3' 276 duration cam w/chrysler solid lifters, shortened push rods, aluminum cam gear, Edelbrock AFB Carb, GM HEI distributor, 8.8mm plug wires, waiting in the garage.
        '63 Avanti R1, '03 Mustang Cobra 13" front disc/98 GT rear brakes, 03 Cobra 17" wheels, GM alt, 97 Z28 leather seats, TKO 5-spd, Ported heads w/SST full flow valves.
        Check out my disc brake adapters to install 1994-2004 Mustang disc brakes on your Studebaker!!
        http://forum.studebakerdriversclub.c...bracket-update
        I have also written many TECH how to articles, do a search for my Forum name to find them

        Comment


        • #5
          You know, you're right! I went out and checked. [u]Both</u> mounts appear to be broken. Well, I happen to have new ones. I have noticed that the Champ uses a through bolt arrangement. Would this fit on my sedan?
          let me rephrase that, would this work better on the sedan?


          Lotsa Larks!
          K.I.S.S. Keep It Simple Studebaker!
          Ron Smith
          Home of the famous Mr. Ed!
          K.I.S.S. Keep It Simple Studebaker!
          Ron Smith
          Where the heck is Fawn Lodge, CA?

          Comment


          • #6
            IIRC,the Champ uses a much larger through bolt than the sedan oem mount. Also the thickness and the OD may be different. Worth checking though.
            Dan

            Comment

            Working...
            X