Announcement

Collapse

Get more Tips, Specs and Technical Data!

Did you know... this Forum is a service of the Studebaker Drivers Club? For more technical tips, specifications, history and tech data, visit the Tech Tips page at the SDC Homepage: www.studebakerdriversclub.com/tips.asp
See more
See less

brakes

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • brakes

    Hi guys,
    I need help. I have a 1963 avanti & have replaced all brake cly, master cly, brake booster,
    check valve, resurface front rotors, front pad, rear shoes, rear brake drum & brake tubing,
    brake tubing fittings, silicone brake fluid& stop light switch.
    but i still can not get more than 1 in of brakes.
    Thanks Lew

  • #2
    Hey I found out if i disconnett the vac hose on the power steering i have 2 in of brakes???
    any ideas.
    Lew

    Comment


    • #3
      quote:Originally posted by lew

      Hi guys,
      I need help. I have a 1963 avanti & have replaced all brake cly, master cly, brake booster,
      check valve, resurface front rotors, front pad, rear shoes, rear brake drum & brake tubing,
      brake tubing fittings, silicone brake fluid& stop light switch.
      but i still can not get more than 1 in of brakes.
      Thanks Lew
      Lew,
      Not sure what you mean by 1" of brakes. Do you mean the brake pedal goes down 1" from the stop at the top until the pedal can't be depressed any more? If so, I think this is about normal (at least for power brake cars). Do the brakes "feel" normal?




      Dick Steinkamp
      Bellingham, WA

      Comment


      • #4
        Sorry i was not clear. The pedal with the motor runing goes down to 1 inch or less from the floor.
        With the vac hose on the power brakes off the pedal it goes down to 2 from the floor.
        Thanks Lew

        Comment


        • #5
          quote:Originally posted by lew

          Sorry i was not clear. The pedal with the motor runing goes down to 1 inch or less from the floor.
          With the vac hose on the power brakes off the pedal it goes down to 2 from the floor.
          I would assume you have air in the lines, OR the rod on the booster
          is not adjusted correctly. There is a specified amount that the shaft
          coming out of the booster needs to extend too. If the shaft is too
          short, then it could result in a lower pedal.

          Tom

          1963 Studebaker Avanti, 102,000, custom made brake brackets to mount 1998 Mustang GT 4 wheel disc brakes (soon to get 13" Cobra front brakes, 2003 Mustang Cobra 17" wheels, GM altenator, will be getting : 97 Camaro Z28 tan leather seats, 97 Camaro Z28 T-56 6-speed trans, Ported 'R3' style Avanti heads with stainless full flow valves, 'R3' 276 duration cam w/chrysler solid lifters, shortened push rods, aluminum cam gear, Edelbrock AFB Carb, GM HEI distributor, 8.8mm plug wires, waiting in the garage.
          '63 Avanti R1, '03 Mustang Cobra 13" front disc/98 GT rear brakes, 03 Cobra 17" wheels, GM alt, 97 Z28 leather seats, TKO 5-spd, Ported heads w/SST full flow valves.
          Check out my disc brake adapters to install 1994-2004 Mustang disc brakes on your Studebaker!!
          http://forum.studebakerdriversclub.c...bracket-update
          I have also written many TECH how to articles, do a search for my Forum name to find them

          Comment


          • #6
            Lew,

            Did you check the pushrod length? Not unusual for the pedal to be higher with the booster disconnected. You have a compound problem if the pushrod isn't right because your not getting enough travel to push the air out when you attempt to bleed.

            I'm assuming you bled the master cylnder before you hooked up the lines. Also, when the system is emptied it's hard to get all the air out bleeding the old fashioned way of "pump and hold". Power bleeding is the best but I've had good resuts with the "one man bleeders" but I just use the cup and have someone pump the pedal until I can't see any air bubbles. Just have to make sure you always have the hose in the cup submerged in fluid and you don't run the master dry.

            Another thing to check is that the calipers aren't switched so that the bleeder screw is not up on top of the caliper. If it's pointing down air can get trapped at the top of the caliper reservoir and not get bled out.

            Ernie R2 R5388

            R2 R5388

            Comment


            • #7
              I had a similar situation once when I changed a MC. The MC or kit must have been different.

              Measure the distance from the back of the MC to the end of the piston where the push rod presses against. Measure this on both the old and the new one. If there is a difference, adjust the push rod to make up the difference. This solvrd my problem.
              Milt

              1947 Champion (owned since 1967)
              1961 Hawk 4-speed
              1967 Avanti
              1961 Lark 2 door
              1988 Avanti Convertible

              Member of SDC since 1973

              Comment

              Working...
              X