Announcement

Collapse
No announcement yet.

Oil Pressure line on '50 170 engine

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oil Pressure line on '50 170 engine

    As long as I have owned my 1950 Champion the oil pressure line has been a weird plastic tube that came off the engine, not the oil pump as in the manuals. This arrangement has started to drip oil onto the exhaust pipe. Up tho this point the oil pressure gage alsways read 30-40 lbs. So I decided to change the line back to the way it was before the PO has made these modifications.

    My question is that I can not find a place off of the oil pump where the oil pressure line should connect. There is no plug or other spot where it would logically connect. I have run my fingers all around the oil pump housing and still can not find any spot where the oil pressure line should connect.

    Could this engine be a 1949? Did they have oil pressure lines in the oil pump housing? Any thoughts or help would be appreciated.




  • #2
    The take-off for the oil pressure line is probably on an oil gallery, drilled and tapped through the outside of the block. check near the back of the block, above the valve cover on the Passenger's side of the car. That's a guess.

    [img=left]http://www.alink.com/personal/tbredehoft/Avatar1.jpg[/img=left]
    Tom Bredehoft
    '53 Commander Coupe (since 1959)
    '55 President (6H Y6) State Sedan
    ....On the road, again....
    '05 Legacy Ltd Wagon
    All Indiana built cars

    Comment


    • #3
      That is correct Tom, ALL of those 1/8" pipe plugs in the block, right side, have oil line pressure in them, so ANY will work fine, the rear being closer and correct, but it gets a copper or steel line up to the head where the flex hose mounts on a head bolt to connect to the tiny copper line across the firewall to the instrument area.

      StudeRich
      StudeRich
      Second Generation Stude Driver,
      Proud '54 Starliner Owner
      SDC Member Since 1967

      Comment


      • #4
        Thanks guys this helps alot! The current setup is off a plug on the passenger side of the block, one nearest the manifold. I thought it had to be off of the oil pump, glad to hear that where it is is ok. I just need to find a fitting to take connect to the copper or steel line that goes up to the flex hose. Thanks again!

        Comment

        Working...
        X