Announcement

Collapse

Get more Tips, Specs and Technical Data!

Did you know... this Forum is a service of the Studebaker Drivers Club? For more technical tips, specifications, history and tech data, visit the Tech Tips page at the SDC Homepage: www.studebakerdriversclub.com/tips.asp
See more
See less

headlights not working..........fix ??????

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • headlights not working..........fix ??????

    I have parking lights and tail but sometimes no headlights. Is the problem a switch ??............Brad

  • #2
    Quite likely. I've recently had trouble with the switch in the Transtar. Turned out it was the blade connector on the terminal that feeds the HL power to the hi-lo switch. I've also seen those hi-lo switches get cranky!

    Miscreant adrift in
    the BerStuda Triangle


    1957 Transtar 1/2ton
    1960 Larkvertible V8
    1958 Provincial wagon
    1953 Commander coupe

    No deceptive flags to prove I'm patriotic - no biblical BS to impress - just ME and Studebakers - as it should be.

    Comment


    • #3
      Problem solved.....dimmer switch was bad.......Brad

      Comment


      • #4
        Cool! [8D]

        Miscreant adrift in
        the BerStuda Triangle


        1957 Transtar 1/2ton
        1960 Larkvertible V8
        1958 Provincial wagon
        1953 Commander coupe

        No deceptive flags to prove I'm patriotic - no biblical BS to impress - just ME and Studebakers - as it should be.

        Comment

        Working...
        X