Announcement

Collapse
No announcement yet.

Is my speedometer broken or what?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is my speedometer broken or what?


    In preparation for bolting the speedometer/gauge panel in my freshly painted dash before installing it back into the car I decided to clean the back side of the instrument panel glass. Now that I have it apart, I have a question:

    The speedometer worked when I took the car apart. Now that I am looking at it here on my desk, I do not see how. There is a tiny shaft that extends from the indicator needle through the face plate but it does not connect to anything. The mechanism which the cable from the transmission inserts into has a shaft extending out of it toward the shaft just mentioned. I think that they are to be connected but they are not. The difference in the size of the two shafts makes it appear that the smaller one might stick inside of the larger one but there is no hole in the larger one or else the smaller one has been broken off inside the larger one.

    Any suggestions will be greatly appreciated.

    Jimmie
    Orleans, Indiana


    1950 CHAMPION -ORANGE COUNTY, INDIANA
    sigpicJimmie
    Orange County, Indiana
    1950 CHAMPION -ORANGE COUNTY, INDIANA

  • #2
    I just spin the brass sleeve on the back of the Speedo that the square end of the cable goes into between my fingers, if the speedometer needle goes up and the odometer turns, I lube the cable and install it for road test.

    If it does not, I take it or send it to a Speedometer Shop, as there is very little a non-qualified person can do with it, but it is a somewhat standard Stewart-Warner unit. That is what the Dealers did, and it works for me.

    StudeRich
    StudeRich
    Second Generation Stude Driver,
    Proud '54 Starliner Owner

    Comment


    • #3
      There is a non-interference magnetic connection between the two, the input shaft and the needle. The section with the needle is sprung, so it takes more rpms of the driving member to turn the needle farther.

      [img=left]http://www.alink.com/personal/tbredehoft/Avatar1.jpg[/img=left]
      Tom Bredehoft
      '53 Commander Coupe (since 1959)
      '55 President (6H Y6) State Sedan
      (Under Construction 617 hrs.)
      '05 Legacy Ltd Wagon
      All Indiana built cars

      Comment


      • #4
        Tom B just explained the magic that makes it work. Thank you very much. A non-interference magnetic connection is just what I was hopin for when I got married. Oh well....
        Dave Warren (Perry Mason by day, Perry Como by night)

        Comment


        • #5
          Okay, and similarly, the speedo in my 1950 champion does not work well, either, after having rebuilt the transmission and also having had the speedo out of the dash. So either I: did not bolt the final flange onto the transmission output shaft down far enough, so that the speedo worm gear in the transmission is just slipping inside and not driving the speedo cable OR I: let the little wrench-turner around the house damage the speedo by pulling the needle around past its stops when he was helping me paint it. Thanks, lad. No go see what Mommy is doing, willya? Any thoughts on what it might be? The cable spins if I disconnect it from the speedo and go out driving, but it's hard to be tooling down the road steering and holding onto the greasy, twirling end of the speedo cable.

          Comment


          • #6
            Oo -- now that I read some more, I realize it may be that after cleaning the speedo, I probably now need to relubricate the speedo head. I think I got some clock oil around to do that. Whoops.

            Comment

            Working...
            X