Announcement

Collapse
No announcement yet.

Transmission questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BrianC
    replied
    Got the 'trans-x", the viscosity seems very thin compared to other products, but i'll give a try. have a delay poblem with cold starts, not gonna judge a can by it's cover. Can't wait to get the tranny back in and see. Thanks for the tip.
    BrianC

    Leave a comment:


  • bams50
    replied
    Yes, any parts store should stock it and know what you mean when you simply ask for "trans-x".

    Robert (Bob) Andrews- on the IoMT (Island of Misfit Toys)
    Parish, central NY 13131

    GOD BLESS AMERICA





    Leave a comment:


  • BrianC
    replied
    Trans-X ?? Is that the full name of the product? Who makes it? Is it easily found? Thanks
    Brian C

    Leave a comment:


  • buddymander
    replied
    For all of the guys who changed fluid and then started having problems..It doesn't make a bit of sense to me. What is more likely is that they didn't refill it properly. The fluid clings to the inside of the tube when you pour it in, and then transfers to the stick, reading "too full". Or sometimes they drain the converter and then add the same amount of fluid that they removed before starting it up. That aerates the fluid, like a milk shake and the pump can't properly pressurize aerated fluid. Other times the filter is installed improperly allowing air to enter the system. I could keep going but the examples are neverending.

    Leave a comment:


  • jimmijim8
    replied
    I have know people to complain of slipping transmissions after changing fluid. Darned if you do and darned if you don't. I've known of some folks that don't change oil but do the filter and replace what is lost. Depending on how much oil your car consumes or leaks could be a decisive factor when contemplating the need for an oil change. I remember the days of 25 cents a quart bulk oil. Dark green stuff. Came in a glass jar with a screw on funnel outlet. Sold at full serve gas stations. You purchased the oil only. The glass jar remained with the attendant so he could refill it from a 55 gal drum. jimmijim

    Leave a comment:


  • sbca96
    replied
    A lot of times changing the fluid "causes" a trans to fail. This has
    happened a number of times on the Impala forum. Someone takes a nice
    operating 150K mile car and decides to change the fluid. After the
    car starts to slip and requires a rebuild. Popular opinion seems to
    point to those suspended clutch particles. They make the fluid thicker
    and actually help the trans shift. Once fresh clean slick fluid is in
    the trans, it no longer can grab. I didnt bother to change the fluid
    in the previously mentioned '78 Camaro, just added the TransX, topped
    off the level and called it good.

    Tom

    Leave a comment:


  • buddymander
    replied
    I used to have a trans business, and there was only ONE trans out of all of them that had nasty fluid that wasn't burned up. So, I wouldn't push it. The clutch packs can wear out slowly enough to shed clutch particles as small as dust and leave them suspended in the fluid. So, your fluid turns nasty brown and leaves few particles in the bottom of the pan.

    Leave a comment:


  • N8N
    replied
    quote:Originally posted by Bill Pressler

    Along these lines, my 'new' '64 Daytona with Flightomatic doesn't seem to want to shift into third unless I let up on the gas at about the time I think it should shift. Then it does. AT fluid looks red and seems overfilled (at least when car is off and in 'Park'; I know I need to check it when warm and in 'Drive').

    I can't imagine this is a good thing.
    Bill,

    check your engine mounts, if they are soft looking replace them (both the front ones and especially the two on the bellhousing) then check the throttle pressure linkage to the trans per the shop manual procedure. Then if it still doesn't shift into third when you think it should start to worry, not before.

    nate

    --
    55 Commander Starlight
    http://members.cox.net/njnagel

    Leave a comment:


  • Bill Pressler
    replied
    quote:Originally posted by jimmijim8

    Bill, your tranny might benefit from the trans-x stuff. Give it a few more miles as is and pay close attention as you are I am sure. I am not a trans expert but my experience with the additive made my 79 Toronado upshift from 2nd to 3rd. Lasted till I got something else. Thousands of miles later. jimmijim
    I think I will try it!

    BTW, thanks to everybody for the help with my pretty-elementary questions. I consider myself sort-of an amateur Studebaker historian and real buff, but alas mechanical knowhow has always escaped me!

    Leave a comment:


  • jimmijim8
    replied
    Bill, your tranny might benefit from the trans-x stuff. Give it a few more miles as is and pay close attention as you are I am sure. I am not a trans expert but my experience with the additive made my 79 Toronado upshift from 2nd to 3rd. Lasted till I got something else. Thousands of miles later. jimmijim

    Leave a comment:


  • Bill Pressler
    replied
    Along these lines, my 'new' '64 Daytona with Flightomatic doesn't seem to want to shift into third unless I let up on the gas at about the time I think it should shift. Then it does. AT fluid looks red and seems overfilled (at least when car is off and in 'Park'; I know I need to check it when warm and in 'Drive').

    I can't imagine this is a good thing.

    Also--"baby steps"!--replaced the broken LF fender "Daytona" nameplate yesterday. Only one clip was still in the fender (in the middle of the nameplate). Couldn't find an open body shop yesterday so bought 3M nameplate adhesive and it seems to have worked fine. Pins on back of the nameplate seemed to go into the fender holes just right.

    Bill Pressler
    Kent, OH
    '63 Lark Daytona Skytop R1
    '64 Daytona Hardtop

    Leave a comment:


  • p71victoria
    replied
    @ buddymander
    There was some material,small shiny slivers. Sometime in the transmission's life it was beaten a little. The filter was pretty much clean, but the fluid on the other hand was pretty horrid. It seems that the fluid hadn't been change it a long time.

    -Chris

    1964 Daytona

    Leave a comment:


  • buddymander
    replied
    p71, did you find much material in the bottom of the pan or stuck in the filter?

    Leave a comment:


  • sbca96
    replied
    We did the TransX fix on my wifes '78 Camaro years ago. It leaked a
    lot of fluid while sitting and would NOT move at all. We needed to
    get the car from Northridge to Santa Barbara, a 90 mile drive. Since I
    was looking at towing it anyway, I figured try the TransX, the closer
    I get to SB the cheaper the tow.

    We added the TransX and it started to move, by the next block it was
    actually making it into 3rd Gear. By the time she got to the freeway
    it was acting normally (about 5 miles). It made it all the way home
    without issue, and STILL works when we need to move the car. It has
    been about 5 years.

    Tom

    Leave a comment:


  • jimmijim8
    replied
    Just baby that tranny along. No jack rabbit starts, and ease up on the gas just when you know it is about to shift. Glad to know it seemes to have worked for you. jimmijim

    Leave a comment:

Working...
X