Announcement

Collapse
No announcement yet.

Carb issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Carb issues


  • #2
    If it's backfiring, I would check the ignition system very carefully. Many time the carburetor gets blamed for problems caused by a poor performing ignition.
    If the throttle shaft is not loose and you put in a rebuild kit with the proper float setting, the carb should be fine.


    1952 Champion Starlight, 1962 Daytona, both w/overdrive.Searcy,Arkansas
    "I may be lazy, but I'm not shiftless."
    "In the heart of Arkansas."
    Searcy, Arkansas
    1952 Commander 2 door. Really fine 259.
    1952 2R pickup

    Comment


    • #3
      No shop is going to be interested in trying to find your mistake. That's what makes it "new parts time". How many turns out are your idle mixture screws?

      Comment


      • #4
        The idle mixture screws are 6 turns out, this is where they were set when I bought the car. Adjusting the idle mixture does not seem to effect anything. As far as the float, I did not adjust it. But I did make sure it was free. I was also told by the shop that the points needed adjusting as well. Could this be a major ignition problem that may cause stalling?

        -Chris

        1964 Daytona 289

        Comment


        • #5
          Run the idle mixture screws in till they touch, back 'em out 1 1/2 turns each. Tweak in and out until it starts to run ruff and average each one. Then set idle to about 500.

          See if this helps.

          [img=left]http://www.alink.com/personal/tbredehoft/Avatar1.jpg[/img=left]
          Tom Bredehoft
          '53 Commander Coupe (since 1959)
          '55 President (6H Y6) State Sedan
          (Under Construction 571 hrs.)
          '05 Legacy Ltd Wagon
          All Indiana built cars

          Comment


          • #6
            Hi Chris: You need a shop manual or find a motors
            auto repair manual, that covers your car. If you are
            going to "clean" the carb. or adjust points, set
            timing, you need to know specs., such as float
            adjustment point and plug gaps, etc. Your carb. is a
            very simple carb. and should not need replacing just
            because of an adjustment. Get you some spec. info, or
            find someone to do a tune up. If your car has been
            flooding, you may have fouled some plugs.

            Tex E. Grier

            Comment


            • #7
              Six turns is too much. More like two, but try turning them in a little at a time until the rpm goes down then back them out half a turn. Set your float correctly. Replace your points plugs condenser rotor cap and wires. Check the dwell with the vacuum disconnected at several rpm's both hot and cold. Check for vacuum leaks by spraying WD40 at the carb base and intake gaskets. Don't burn your house down.

              Comment


              • #8
                If you are having backfiring, that is almost always ignition or timing. Check your spark plugs to be sure they are clean and gapped properly. Is your distributor worn badly? If you can take the cap off and wiggle the shaft you can check for free play - should be very little. If it isn't too worn, put in a new set of points and gap them to the book (I seem to remember .018 to .020, but I could be wrong). Be sure your distributor clamp is tight. If the backfire is still there, retime it with a timing light. It's also possible the coil may be overheating and causing the same symptoms.

                Comment


                • #9
                  Thanks to everyone! This is a good list of thing for me to check in the morning.

                  -Chris

                  1964 Daytona 289

                  Comment


                  • #10
                    I would also check the compression. A bad intake valve will cause it to backfire through the carb.

                    GARY H 2DR.SEDAN 48 STUDEBAKER CHAMPION NORTHEAST MD.

                    Comment


                    • #11
                      Make sure the choke stove hot air circuit through the exhaust crossover under the carb is working properly. Be sure the tube within the crossover is not burned through, allowing exhaust gas to be drawn into the carb through the choke's vacuum circuit. BP
                      We've got to quit saying, "How stupid can you be?" Too many people are taking it as a challenge.

                      Ayn Rand:
                      "You can avoid reality, but you cannot avoid the consequences of avoiding reality."

                      G. K. Chesterton: This triangle of truisms, of father, mother, and child, cannot be destroyed; it can only destroy those civilizations which disregard it.

                      Comment


                      • #12
                        Has the fuel pump been modified, to electric, maybe? How long have you had your car?
                        Dave Warren (Perry Mason by day, Perry Como by night)

                        Comment


                        • #13
                          I have had similar problems and have just in the last two weeks gotten mine to where she should be. What everyone is saying here is right on, don't neglect anything. In my case, my Prestolite distributor needed rebuilt (Cam and weights), and I had a vacuum leak, (not to mention the last time it had its plugs and wires changed was almost a decade ago) after I fixed both of those, she ran like a new car. At first I thought my problem was the carb, too, but it turns out that it wasn't. Don't replace the carb until you have gone over the easier, cheaper fixes/adjustments first. (because, even if the easier, cheaper fixes aren't the problem, it never hurts to get them up-to-date and ease your mind)



                          1963 Lark, waiting for spring...

                          Comment


                          • #14
                            Chris:

                            Your posting reminds me of when we first got our 64' Cruiser with its 289. It had some issues similar to yours, not exactly but similar. The first thing the guys in our chapter asked me was, does its still have its original Prestolite distributor? They then went on to explain to me that many of those 63'-64' V-8 Prestolite distributors are worn out by 50K miles. I replaced mine with a mid 50s Delco with Pertronix ignition and instantly the problem was solved. Not saying that this is your problem, but it is a very important component to not overlook during your troubleshooting.

                            Dean Croft
                            Roseburg,OR

                            CLEM DESEE
                            Dean




                            CLEM

                            Comment


                            • #15
                              Do they sell a recurve kit for those distribtors? Maybe recurve it ( lighter springs & weights )

                              Comment

                              Working...
                              X