Announcement

Collapse
No announcement yet.

1955 Studebkaer President-no electrical gauges after changing glass panel out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedo / Tach / Gauges: 1955 Studebkaer President-no electrical gauges after changing glass panel out

    Just when I thought it was safe to back in the water, err.. the electrical.
    Took out the instrument cluster on the Pres. Put in new temp and fuel gauge. None of the electrical gauges worked when I started the car. Was very meticulous about marking what wire went where in the back. Just wondering if I could have bumped something or did my ammeter all of sudden go bad? (Sort of doubt it). I've had quite a run with the electrical lately. Thanks for any help. I'm going back out to check again for anything that might be obvious. Thanks in advance for any help. I do I have a VOM but I don't want to fry that checking for amps.

  • #2
    It wasn't too long ago that I had an issue with my generator overcharging. I suspect that the overcharge is still haunting me. When I unhooked the back of the ammeter, it immediately went into the "D" range and remained there. This occurred when I was just undoing the wiring in the back. The battery was disconnected! After installing a newly rebuilt generator a week or so ago, I had been driving the car a little. Everything was working fine. I think just "Bumping" the back with the wrench today must have caused this to happen now, but the real wear probably occurred with the old generator?...
    At any rate, I'm betting a new ammeter is probably in order. Thanks for any thoughts on this.

    Comment


    • #3
      You say you took out the instrument cluster to replace the gauges. I would start there and retrace your actions. I know its an old saw but 90% of electrical problems are connected to a poor or non-existent ground. Did you do something to interfere with proper grounding ??

      Comment


      • #4
        You are disconnecting the battery before working behind the dash, right?
        RadioRoy, specializing in AM/FM conversions with auxiliary inputs for iPod/satellite/CD player. In the old car radio business since 1985.

        17A-S2 - 50 Commander convertible
        10G-C1 - 51 Champion starlight coupe
        10G-Q4 - 51 Champion business coupe
        4H-K5 - 53 Commander starliner hardtop
        5H-D5 - 54 Commander Conestoga wagon
        56B-D4 - 56 Commander station wagon
        60V-L6 - 60 Lark convertible

        Comment


        • #5
          Well, maybe my fault-
          Additional investigation reveled a cracked ceramic head and blackened pole on one side of the ammeter. I can't think of any good reason why that would happen so maybe something in my install caused it. ? Did I zig earn I should have zagged? I did notice that the grommets on the back were extremely tight, but they've probably been that way for years. I always disconnect the battery before I do anything on the car, unless for some reason the engine has to be running. When I first got my car I fried a couple of fuses in the OD. After that I have always left the battery disconnected when in the garage. Although if you only take off the positive ground, still possible to fry things if you go from negative connect to ground! Thanks for the thoughts guys. The saga continues...

          Comment


          • #6
            I am quite confused about disconnecting your positive battery terminal and still frying something by grounding it.

            Comment


            • #7
              I guess it would be more like shorting it out. Sorry. Sometimes a metal wrench can do a lot of damage if it touches the wrong things at once.

              Comment


              • #8
                Some gauges have two binding posts on the back that are only insulated from the mounting hardware by heavy cardboard pads/insulators. They can become damaged or misaligned and allow a dead short.

                If one post on the battery is disconnected, then no, it is not possible to fry anything unless you actually short circuit the battery poles themselves.
                Last edited by Skip Lackie; 05-27-2020, 03:34 AM. Reason: typo
                Skip Lackie

                Comment


                • #9
                  The ammeter is the only electrical instrument in the cluster that does not depend on a ground to operate. The fuel gauge and the temperature gauge do. The Speedster has a fiberglass dash panel, so a ground wire to the instrument cluster is required.
                  Gord Richmond, within Weasel range of the Alberta Badlands

                  Comment

                  Working...
                  X