Announcement

Collapse
No announcement yet.

One last try on this DG200

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • doofus
    replied
    Does sound like the stator's one way clutch. wifes 57 Silver hawk makes a swishing sound during multiplacation but quiets down as stator locks up. been that way since 2011 and is hi on the repair list,,,,i guess. Luck Doofus

    Leave a comment:


  • lelshaddai
    replied
    Thank you Ross. That sounds like what it is doing. I guess it may be time to jack it up and replace it with the DG250. It is complete with torque converter. No harm giving it a try. Told it worked when pulled.

    Leave a comment:


  • Ross
    replied
    Sounds like the thrust washers inside your convertor have perished and or the reactor clutch is slipping. The later in particular will give a very slow takeoff as the convertor acts a fluid coupling rather than multiplying the torque as advertised. On the few convertors with problems that I have heard there is a lot of rubbing noise and greatly reduced acceleration. Changing fluid and adjustments will not do a thing.

    Leave a comment:


  • studegary
    replied
    It could be a band sticking/locking up and then releasing or the torque convertor hanging up. These are my ideas from reading your post. Did you change ALL of the fluid at once (transmission and torque converter)? Have the bands been properly adjusted?

    Leave a comment:


  • lelshaddai
    replied
    Just sending it out one more time to see if anyone who has not seen it may have an idea. I just did not want to pull the trans but I will if I have too.

    Leave a comment:


  • StudeRich
    replied
    That IS a hard one to diagnose from afar, but it does seem to be Torque Converter related due to it having a Lockup unit.

    The Trans. could be fine but it sure would be a lot of work for nothing if you replace the Converter and still have the Problem.
    Please don't shoot the messenger!

    Wasn't that pretty much the Prognosis on your previous 3 or4 Posts?

    Leave a comment:


  • lelshaddai
    started a topic Transmission / Overdrive: One last try on this DG200

    One last try on this DG200

    I am going to give one last try to see if anyone has any ideas on the problem with the transmission on the 51 Commander. She is still slow, really slow, slower than normal in taking off in 2nd or 1st. Gives out an awful screaming/squelching sound for the first 3-5 seconds. Then after, runs fine with good pickup speed. Drops down fine and has good speed. Does this in 1st, 2nd(when starting out) and Reverse. I do not believe this is engine related. I drained all fluid and replaced with fresh Dex/Merc according to the manual. I still have an extra DG200 and DG250 trans. Just thought if I could fix this the better. Could bands be out of adjustment? But all three? Again only sluggish for first 3-5 seconds on takeoff, then normal. When stopping she downshifts to 2nd for next takeoff just fine. Any adjustment I might be missing. If I have to rebuild I will try one of the other transmissions I have first.
Working...
X