Announcement

Collapse
No announcement yet.

transmission oil leak

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Baildon
    replied
    Thank you Gentlemen on your comments on my T10 Oil leak much welcomed.

    Leave a comment:


  • Ross
    replied
    The front bearing should be the shielded type; that is a metal cover, not a seal, facing the inside of the trans. That sheds most of the oil off and the threads cut onto the input shaft take care of the rest. I think pretty much everyone in the world did it the same way on manual transmissions because it worked really well. I am wondering if someone installed a bearing w/o a shield. Also make certain that the drain in the nose casting is down and and the drain path back into the case is clear. It is possible to install those rotated and then the oil has nowhere to go. If that is trans oil you are seeing in your bell housing, I would expect your clutch to be soaked because it would dump it out inside the pressure plate.

    Leave a comment:


  • doofus
    replied
    Early T10 trans had no case vent.I have one in my 62. run lube about 1in low or so.reverse spiral cut inside input collar pumps lube back. Merry Christmas, Doofus.

    Leave a comment:


  • rkapteyn
    replied
    Had a mystery oil leak on the rear of my T10.
    Changed rear seal twice and it still leaked.
    Turned out to be the plug on the slip joint had rusted
    out and caused the leak. It looks like a freeze plug.

    Leave a comment:


  • DieselJim
    replied
    Is the vent plugged up? Internal pressure will make leaks.

    Leave a comment:


  • JoeHall
    replied
    Originally posted by jrlemke View Post
    Doesn't the bearing have a seal on one side? It's been a long time since I had a B/W apart, but I seem to remember a seal on the clutch side of the front trans bearing. -Jim
    No seal, just a slinger. There is a gasket between the flange and transmission body, but I doubt it could leak if not gasket. Perhaps the motor rear main seal? But I doubt a leak from there would not be getting onto the clutch. Possibly the transmission is way overfull?

    Leave a comment:


  • jrlemke
    replied
    Doesn't the bearing have a seal on one side? It's been a long time since I had a B/W apart, but I seem to remember a seal on the clutch side of the front trans bearing. -Jim

    Leave a comment:


  • StudeRich
    replied
    Something has to be wrong, like over filled or wrong lube.

    It SHOULD be 85/90 or 90 Wt. GL-1 or Synthetic Redline Gear Lube.

    There IS a Gasket on the the Front Input shaft support (Cone), that can leak but the shaft should not, it needs no "Seal", I have never seen a Manual Trans. with Gear Lube that has one, Certainly not a Borg Warner.

    They never leak, so there IS no "Fix".

    Leave a comment:


  • studegary
    replied
    Originally posted by Baildon View Post
    Have been using gear oil in the trany Has tail shaft seal but no input shaft seal or slinger . leaks transmission oil out past the bearing in to the clutch housing every time you park after a run.
    Have tried filling it to about one inch below the fill plug? Do you park it level, facing downhill or facing uphill?

    Leave a comment:


  • Baildon
    replied
    Have been using gear oil in the trany Has tail shaft seal but no input shaft seal or slinger . leaks transmission oil out past the bearing in to the clutch housing every time you park after a run.

    Leave a comment:


  • 64V-K7
    replied
    The 62 T-10 does not show any seals other than for the side cover shifter levers and tail cone.

    http://www.studebaker-info.org/Avant...10/ST10man.pdf

    Is your leak gear oil or engine oil?
    Last edited by 64V-K7; 12-24-2017, 12:08 PM.

    Leave a comment:


  • Baildon
    started a topic Transmission / Overdrive: transmission oil leak

    transmission oil leak

    I have a 1962 GT Hawk with a T10 and leaks oil badly out the front into the bell housing. On taking the transmission apart ,I find it has no front seal or slinger . The front flange has no place to install a seal. Drawing in the shop manual does not show a seal or slinger. I this the way they were made ? If so now can one stop the leakage I have my own idea but would like comments from others that had the same problem.
Working...
X