Announcement

Collapse
No announcement yet.

AM Radio Noise Filters

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Electrical: AM Radio Noise Filters

    I have installed a new Custom AutoSound AM-FM radio in my '64 Avanti. All is well except terrible alternator noise on AM Radio. FM is fine. There are filters that are installed before the radio antenna jack goes into the car and others that are installed before the switchable 12V lead goes into the radio. What noise filters have worked for others? There are tons of them on e-Bay. Thanks for any hints.

  • #2
    I know you can take the power wire off the alternator or remove the belt then start the engine to see if the static goes away. At least you can eliminate the alternator that way. i tried an in line filter on the radio power wire, then a filter on the antenna wire. I also tried a resistor on the alternator, no help. I found a plug wire that wasn't completely plugged into the plug, it was arcing. That would do it but I haven't started the engine to verify if that was the problem. The filters won't help if you're putting a filter where it's not needed. I also have a custom autosound AM-FM. I only get static when I play the radio with the engine running...CD, IPOD no problem.

    treblig

    Comment


    • #3
      Constant pitch noise is ignition interference...a whine that increases or decreases with engine rpm's is alternator noise. Make sure which you have before trying to eliminate it.
      Poet...Mystic...Soldier of Fortune. As always...self-absorbed, adversarial, cocky and in general a malcontent.

      Comment


      • #4
        I don't know anything about any "Static Filters", Studebaker used Condensers on the Alternator, Voltage Regulator, and Coil plus the Distributor and Spark Plug Stainless Steel Shields and had no problem when New, so if using Original equipment you should not have a problem.

        Make sure your Braided Copper Ground Strap is properly in place on the Oil Pressure Gauge copper tubing.
        StudeRich
        Second Generation Stude Driver,
        Proud '54 Starliner Owner

        Comment


        • #5
          Make sure your Braided Copper Ground Strap is properly in place on the Oil Pressure Gauge copper tubing.[/QUOTE]

          Rich,
          Is that ground strap specifically for radio noise or is there some other purpose? I removed mine when cleaning up the wiring in the engine compartment but don't use the AM
          radio anyway.

          Comment


          • #6
            The whine from the alternator is traveling down the main wiring harness to the radio and not the antenna. There are filters made to reduce or eliminate the noise coming through the wiring. Radio Shack used to have them, but I would think that any shop that does auto radio installation would have the filters or can get one for you. I would also recommend contacting Custom Auto Sound directly to get their recommendations on how to eliminate the noise. There is also the possibility that the alternator is failing such as a leaking internal diode that is causing your problem. I had that problem recently with a late model GMC Yukon. The alternator was failing which caused a whine in the factory sound system. Replacing the alternator solved the problem. Bud

            Comment


            • #7
              Thanks for the responses everybody, but it is not a whine. It is a loud overcoming noise totally drowning out AM signal when the engine running. FM is fine, iPod is fine. I see antenna filters on eBay but I don't want to waste money and time on something that doesn't work.

              Comment


              • #8
                Just stumbled across this thread. I'm already late with this mornings chores, so I'm going to make a suggestion without reading all the responses. So forgive me if this has been covered. Just as an attempt to isolate the source, how 'bout disconnecting the antennae and see if the noise changes. I would suspect, if the noise remains, it is related to power supply and ground issues. If it is greatly reduced, I would suspect the antenna. Next, if you have a spare antennae, and a long lead, you could plug it into the radio, move it around, and see what effect location has on performance. Of course, you would also need a "gator clip" ground wire to evaluate grounding issues/locations.
                John Clary
                Greer, SC

                SDC member since 1975

                Comment


                • #9
                  Originally posted by Ted Johnson View Post
                  Thanks for the responses everybody, but it is not a whine. It is a loud overcoming noise totally drowning out AM signal when the engine running. FM is fine, iPod is fine. I see antenna filters on eBay but I don't want to waste money and time on something that doesn't work.
                  So, it sounds like it is due to ignition noise. Do you have radio suppression ignition wires? Corvette had metal covers over the plug wires to help shield ignition noise. I'm not familure with the Avanti, but didn't they also have metal covers?

                  Comment


                  • #10
                    Send a "PM" (personal message to radio roy. One nice thing with the forum is if you get a pm & you don't go into the forum you are sent an e-mail saying you have a message.
                    59 Lark wagon, now V-8, H.D. auto!
                    60 Lark convertible V-8 auto
                    61 Champ 1/2 ton 4 speed
                    62 Champ 3/4 ton 5 speed o/drive
                    62 Champ 3/4 ton auto
                    62 Daytona convertible V-8 4 speed & 62 Cruiser, auto.
                    63 G.T. Hawk R-2,4 speed
                    63 Avanti (2) R-1 auto
                    64 Zip Van
                    66 Daytona Sport Sedan(327)V-8 4 speed
                    66 Cruiser V-8 auto

                    Comment


                    • #11
                      As others have mentioned, try this:
                      -disconnect the fan belt
                      -run the engine
                      -if the noise is gone, the problem is in the alternator and is coming in via the power line
                      -if the noise is still there, the problem is in the spark plug wires and is coming in via the antenna.

                      If the problem is in the spark plug wires, replace them with the type that say radio suppression, or some such nomenclature. There are a few different kinds of wires.

                      If the problem is in the alternator, see if Crutchfield has any filters, or see if your alternator is getting wonky. Since the FM and iPod functions are fine, the problem is likely noise coming in to the antenna from the spark plug wires.

                      Either way, make sure all the special shielding is present on the engine and that all the shielding is properly grounded to the frame. Make sure the antenna coax shield is connected to the antenna plug.

                      The proper way to eliminate noise is to stop it at the source. Attempting to filter it out at the antenna is a losing game.
                      Last edited by RadioRoy; 11-15-2016, 11:33 AM.
                      RadioRoy, specializing in AM/FM conversions with auxiliary inputs for iPod/satellite/CD player. In the old car radio business since 1985.

                      17A-S2 - 50 Commander convertible
                      10G-C1 - 51 Champion starlight coupe
                      10G-Q4 - 51 Champion business coupe
                      4H-K5 - 53 Commander starliner hardtop
                      5H-D5 - 54 Commander Conestoga wagon
                      56B-D4 - 56 Commander station wagon
                      60V-L6 - 60 Lark convertible

                      Comment


                      • #12
                        Today I came across a NOS Dealer Radio Suppression Kit, part number 1540528, and the instruction sheet is below. This should help answer some of the questions on radio suppression from the factory.

                        Click image for larger version

Name:	Radio Supression Instructions1.jpg
Views:	1
Size:	117.8 KB
ID:	1711174
                        Dan Peterson
                        Montpelier, VT
                        1960 Lark V-8 Convertible
                        1960 Lark V-8 Convertible (parts car)

                        Comment

                        Working...
                        X