Announcement

Collapse
No announcement yet.

Nice drive went bad.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 52-fan
    replied
    Originally posted by Nelsen Motorsports View Post
    The one I use on the SW gauge on my 383 is copper, it will never wear out and it looks cool doing it.
    Actually copper will wear out. The flexing and vibration will eventually harden it and cause cracking. That is why, even though polished it looks cool, copper is not recommended for fuel lines.
    Now, I don't know how many years this would take. Obviously the gauge comes with the line so it may be fine for a long time.

    Leave a comment:


  • Son O Lark
    replied
    Whatever you use, MAKE SURE IT'S FLEXIBLE! Those grease gun flex hoses look like they might work.

    Leave a comment:


  • Warren Webb
    replied
    Alex's comment brought back a memory of using an aftermarket guage cluster years ago that used a copper line. In the instructions they said to loop the copper line 2 or 3 times between the engine & firewall, then thru the firewall to the guage. The replacement lines I've seen have an adapter on them to conform to the Stude line. Hope Jim finds the correct fittings & makes a stainless braided line that will no doubt be alot stronger than just a rubber line.

    Leave a comment:


  • dean pearson
    replied
    Nice !
    That thing sounds great and looks good going down the road.
    Good job!

    Dean.

    Leave a comment:


  • Nelsen Motorsports
    replied
    The one I use on the SW guage on my 383 is copper, it will never wear out and it looks cool doing it.

    Leave a comment:


  • dean pearson
    replied
    At least it didn't catch fire, oil on a hot exhaust can get ugly.

    Dean.

    Leave a comment:


  • JoeHall
    replied
    That happened to me once in the GT, on I-10 near Los Angeles, 15-20 years ago. I lost a 2-3 quarts of oil before noticing the gage read zero. I picked up a nail along side of the road, and inserted it upside down, between the fitting and the adapter in the head. Once the parts were tightened down, the flat head acted as a stopper, and sealed it up the tight as a drum. I happened to have two quarts of oil in the trunk, so it was a lucky day.
    In the Marine Corp, with Tanks, we called this sort of thing "field expedience"; it was common, and often even encouraged.
    I have never walked a step due to a broken down Stude, but I have used a lot of field expedience

    Leave a comment:


  • Milaca
    replied
    Perhaps you could have plugged the line and drove without the gauge reading? Better safe than sorry I suppose. At least you had a nice drive up to that point!

    Leave a comment:


  • 52 Ragtop
    replied
    "I wonder if anyone has ever fabricated a stainless steel connection or perhaps a woven steel armored reinforced oil line."

    Once I find the correct fittings, I'll be able to do them in braided stainless lines, I'm thinking maybe just a little longer than the originals!

    It's always a good idea to carry a spare in the glove box too.

    Jim

    Leave a comment:


  • okc63avanti
    replied
    Apparently this is a common failure as I have heard of these rubber hose connections aging and splitting several times on the SDC Forum. I wonder if anyone has ever fabricated a stainless steel connection or perhaps a woven steel armored reinforced oil line.

    Leave a comment:


  • davepink53
    started a topic Nice drive went bad.

    Nice drive went bad.

    My Wife and I went on a pleasant Sunday drive with our club to Phillip Island in our "71 Avant 11. Great day untill the oil line from the engine to oil gauge split. Oil everywhere and smoke pouring out from under the car from the hot exhaust.
    Travelled the last 102 klms home on a tow truck.
Working...
X