PDA

View Full Version : Speedo woking intermittently



mike gaines
09-24-2006, 02:49 AM
My speedo worked fine for about a 12 hours after I got the car , I have checked that the cable is not broken , nor is it kinked , I replaced the cable end drive gear , seemed to fit into the gearbox ok , again worked fine but went to use the car the next day and it has again stopped working , checked everything again and cant find a fault , is there a special way the gear end of the cable is supposed to fit into the gearbox ? any ideas ?

GTtim
09-24-2006, 09:22 PM
Okay Mike let's try to figure this out. If you take the cable off the back of the speedo and try to twist the square part that sticks out does it move? If it does then the gear isn't engaging or the cable isn't seated in the gear. If the cable is firmly seated and you can't twist it from the upper end, then the problem is in the speedometer. Did you notice when you were driving, did the needle move at all and/or do the mile numbers keep turning? That would indicate that the speedo head is needing repair. Try those and come back for more detailed help. Good luck.

Tim K.
'64 R2 GT Hawk

mike gaines
09-26-2006, 12:30 AM
Thanks GTtim , all sorted but it looks as though the snap ring that holds the cable end into the gearbox extension is not the original shape and may be lifting the cable to the point that it is lifting the drive ball free of the gear inside the gearbox housing , will wait a few days and let you know if this is indeed happening,