PDA

View Full Version : master cylinder?



Marrina
09-14-2006, 07:07 PM
Hello,
I have a 62 studebaker that is having a brake light problem. When the vehicle get warm (by ambient temperature outside or from driving) the brake lights illuminate and drains the battery. The master cylinder has been adjusted, but this has not stopped the problem. The master cylinder has been replaced and I still have the same problem. Any advise would be helpful. Thank you [:I]

N8N
09-14-2006, 07:33 PM
check the pedal free play, make sure the tiny return hole in the master cylinder is not plugged, and if this is a Hawk, check the Hydrovac and the hose to it. If the Hydrovac hoses look original, might want to replace them both. Actually all hoses should be replaced if they look original, but only the feed to the Hydrovac would cause the brake lights to remain on.

Finally, if this is solely a temperature related issue and the brakes don't seem to be dragging, just replace the pressure switch. It's cheap at your FLAPS and easy to replace.

good luck,

nate

--
55 Commander Starlight
http://home.comcast.net/~njnagel

64V19816
09-14-2006, 08:09 PM
And are your brakes locking up and the pedal getting real high in just a bit of driving? That little return port hole is plugged up. Open your master cylinder and work the pedal linkage with a big screwdriver. If you dont see a big squirt of brake fluid coming up that hole is plugged and pressure builds up. I took an .030 minature drill bit on my dremel, and after draining and paper toweling out the MC gently drilled in. The corrosion went out, the brake fluid could get to where it had to go and all was well. You should check your power brake rod measurement too, like the shop manual.