PDA

View Full Version : Carb problems on R2



Dan White
06-19-2007, 08:36 PM
I had Dave T-Bow rebuild my R2 '64 Hawk's carb and I am having flooding problems. The floats are where they are supposed to be. However, when I go to start it you don't dare hit the accelerator pedal or it will be flooded. Anyone have some experience setting up an R2?

Thanks



Dan White
64 R1 GT
64 R2 GT

bige
06-19-2007, 11:06 PM
Do you mean gas is coming out the top of the carb or the engine won't start because it's got wet spark plugs?

Ernie R2 R5388

http://i146.photobucket.com/albums/r241/AvantiR2/track.jpg

Dan White
06-20-2007, 06:46 AM
Wet plugs!

Dan White
64 R1 GT
64 R2 GT

bige
06-20-2007, 09:27 AM
Dan, I wouldn't blame the carb just yet, but with bonnet off have someone crank the engine and see if any gas comes out of the bowl vents or through the venturis. If nothing is overflowing I doubt your flooding the engine.

I stopped using Champion plugs in my old cars because they seemed to stop working the minute they got wet. Also, if the ignition is weak or timing too far retarted your plugs stay wet because they are not firing at the right time and combustion is too weak to burn all the fuel in the cylinder.

I use AC plugs R44S, I think, I have to look to be sure as they have been in there for 3 years.

Also while the bonnets off amd the car is cold make sure the choke is working.

ErnieR



http://i146.photobucket.com/albums/r241/AvantiR2/track.jpg

bige
06-20-2007, 10:06 AM
Just looked, I ran R44S but now R43S, either will work.

ErneiR

http://i146.photobucket.com/albums/r241/AvantiR2/track.jpg