PDA

View Full Version : Guages Mounting Pods



curt
06-04-2007, 12:15 PM
Is there a secret on a 1955 President when attaching the spedo and gauge mounting cluster/pods into the dash holes. I was trying to mount the pods and it seems imposible to get the mounting brackets to fit into the rectangular mounting holes on the back side of the dash . Lack of room and vision play a part but does one attach the mounting brackets on the pods after the pods are through the dash holes? That seems to be the only way, but any help will be appreciated.

Roscomacaw
06-04-2007, 01:40 PM
You've got a late 55 President sedan, right? I say that because there's a great deal of difference between the earlier - flat windshield sedans and what you've got.

That said, I don't see how YOU COULD put the instruments into the holes with those brackets attached. What's with the "rectangular" mount holes??? On the clusters or the dash???

Miscreant adrift in
the BerStuda Triangle
http://images.andale.com/f2/115/106/906179/2006/12/7/truckonhill3.jpg

1957 Transtar 1/2ton
1960 Larkvertible V8
1958 Provincial wagon
1953 Commander coupe

curt
06-05-2007, 03:38 PM
Late '55 is correct. I see no way to put a square peg into a round hole, either. I now have the gauge pod in and I'm connecting wires. The spedo pod will be a above average undertaking. I have tried to route the wires to leave space but these big hands will, at best, have a mighty small space to operate from. I bet I spent two hours getting the one pod in. At least it was done without any corner cutting.