PDA

View Full Version : '47 Champ 6 runs but sputters...help



bradnree
04-30-2007, 06:29 PM
I have a '47 Champ 6 that now runs which it hadn't for years. I cleaned the tank out of the car with draino and thoroughly rinsed it. Blew the line clean with carb cleaner. Fresh gas. New fuel pump. In line fuel filter. Rebuilt carb. It is getting fuel. The engine sputters and very very mild backfire once in awhile in the carb fast or slow. Rough idle. Has new points, rotor, wires, plugs, but old cap and condenser. The head has been removed and new gasket. Valves were going up and down. No smoking. It doesn't smooth out when warm...........Brad

vegas paul
04-30-2007, 06:34 PM
timing & firing order ok?

Las Vegas, NV
'51 Champion Business Coupe G899965 10G-Q4-1434
http://i151.photobucket.com/albums/s144/vegas_paul/graciestude.jpghttp://i151.photobucket.com/albums/s144/vegas_paul/1462673_2_350.jpg

bradnree
04-30-2007, 06:55 PM
I will check that again.....Brad
quote:Originally posted by vegas paul

timing & firing order ok?

Las Vegas, NV
'51 Champion Business Coupe G899965 10G-Q4-1434
http://i151.photobucket.com/albums/s144/vegas_paul/graciestude.jpghttp://i151.photobucket.com/albums/s144/vegas_paul/1462673_2_350.jpg

John Kirchhoff
05-01-2007, 09:24 AM
One way to find out if it's fuel starved is when it's running is to squirt little shots of starter fluid into the carb. If it smooths out, then it's not getting enough fuel and you need to look for crudded up jets or such. If it doesn't smooth out any and it isn't smoking black from overfueling, then you may need to do as vegas paul said and recheck the electrical system.