PDA

View Full Version : Best spark plug for 64 Avanti R2 ?



morphis
03-29-2007, 03:43 PM
A quick review of problem . It bogs down when put into gear. The car came from a museum and i bought it at auction. It had the wrong carb. on it so i put on a edelbrock till i find a blow thru. . The trans dipstick was wrong and i added 5 qt of fluid. Just checked the compression and has 150 on all eight. Thats good ! But the plugs are sooty , . The manual calles for champion J-9-4 and autolite 216 were in the engine. I am going to buy a new set and would like some advise about what plugs work for you. Brand & heat range for street use.

StudeRich
03-29-2007, 05:22 PM
Actually the factory used J12Y and a UJ12Y resister would be easier to find or the "New" number, it also crosses over to NGK, and Bosch numbers. The lower than 12 numbers are for "sustained high speed and racing, (colder) plugs. Be sure you use a 3/8" reach, not the standard Studebaker V-8 7/16" ones![:0]

As far as the brand is concerned, it's strictly a matter of personal preference! I like the *** & German plugs better, as I believe in the day when these engines were built the best you could buy (or as good as any) was the Champion that Stude. used. Nowdays however I think others have far surpassed the quality of the New, sold-out Champion Co.

On member Nate's site I found the NGK # is BP5S and the Bosch # is W8F You can find all kinds of GOOD stuff here: http://members.cox.net/njnagel/files/interchange.pdf

StudeRich
Studebakers Northwest
Ferndale, WA

GTtim
03-29-2007, 05:36 PM
J12YC have been working great for me.

Tim K.
'64 R2 GT Hawk

bige
03-29-2007, 05:55 PM
The bogging when you put in gear could be ignition timing. Try advancing it a little. If it has the right distributor it should be set at 24-26 degrees with the car idling at 1600 RPM vacuum advance disconnected.

ErnieR

http://i146.photobucket.com/albums/r241/AvantiR2/avnatiglamour007.jpg