PDA

View Full Version : Heat riser



64V-K7
03-28-2007, 07:17 PM
I already sent this to StudeBOB, but he must be off somewhere tending to his flock...
I have this immediate problem.... The weight has fallen off the heat riser, is now lost and in all probability, the flapper, although movable, doesn't function properly.

When I fooled with it, this afternoon, I found the spring is also bad, as it broke off and left maybe 3 coils on the split shaft.
I don't have the time right now to do it right and remove everything, so want to fasten it in place, open. Of course you can't see inside the pipe, to tell what position, the flap is.
I pulled an old one off the shelf and would like to presume these are all the same but may not, necessarily, be so. On this one, the flap, inside the pipe, is open, when the slot on the shaft is horizontal, or inline with the spacer. Can anyone verify this?

Thanks


Bob Johnstone
http://www.studebaker-info.org/7168422/sig2.jpg

GTtim
03-28-2007, 08:37 PM
The one I have on the shelf is the same, the slit is oriented 90 degrees to the flap. Another way to look at is to turn the flap to open, turn the slotted end clockwise. Does that help?

Tim K.
'64 R2 GT Hawk

StudeRich
03-28-2007, 08:54 PM
If you had the TIME the best way to deal with it (especially in warm climates) is to remove it from the car, remove flapper & shaft then drill and tap both sides of shaft holes to a Std. size Allen screw and Locktite two allen screws into it. Then you are DONE for a lifetime! [^]

Or...if you have the MONEY just get a NEW one! [^]

StudeRich
Studebakers Northwest
Ferndale, WA