PDA

View Full Version : Overdrive



arkiejazz
06-13-2006, 10:52 AM
[:o)]Hi guys, some of you may know that I'm temporarily here in Lubbock, Texas. I have been using my '63 Champ V8 1/2 ton with overdrive for the past 3 weeks without any problem at all, save for poor gas mileage. Well, yesterday on the way to the shop, the overdrive was working just fine...and again at lunch it was working properly. Then, come 5 O'Clock, the overdrive refused to work at all....no free-wheeling, nothing....This morning, I checked the most obvious thing first....the kickdown switch fuse....it tested good. So...what's my next diagnostic?
[:o)]

steve blake

Roscomacaw
06-13-2006, 12:09 PM
Ground the wire from the governor. The solenoid should click. Look for good connections on the kickdown switch. If connections are good and solenoid doesn't respond to grounding of the gov wire, I'd be lookin' hard at that solenoid.[}:)]

Miscreant at large.

1957 Transtar 1/2ton
1960 Larkvertible V8
1958 Provincial wagon
1953 Commander coupe
1957 President 2-dr
1955 President State
1951 Champion Biz cpe
1963 Daytona project FS

Roscomacaw
06-13-2006, 02:26 PM
I've been on the phone with Steve this morning and we're trying to weed out the problem on this late Champ. I had him confirm whether or not it's got a 2-wire or 3-wire OD solenoid and it has a 2-wire. It should have a 3, so I've directed him to look on the firewall and see if it's got a relay W/fuse he can check.
I'll report back with what he finds. I've got both a good used relay or Solenoid if it comes to that. One way er ta uther, we'll get that V8 back to loafin' along.:D

Miscreant at large.

1957 Transtar 1/2ton
1960 Larkvertible V8
1958 Provincial wagon
1953 Commander coupe
1957 President 2-dr
1955 President State
1951 Champion Biz cpe
1963 Daytona project FS