PDA

View Full Version : '55 PRESIDENT REAR BRAKE DRUMS



RHO
03-12-2007, 06:20 PM
Need a source for '55 Studebaker President brake drums. We finally got the brakes removed from the car over the weekend and the drums are pretty badly scored AND missing chunks (sizable on one side)that I'm wondering could cause some vibration at the back wheel. In the interim, all four drums have been taken for turning.
This was most unusual (at least for me) on the driver's side in that the brakes/drums came off the car but the hub remained on the axle shaft. Did get the hub off today after applying a propane torch for a few moments and then a few swings of the big hammer on the wheel puller with a lug nut wrench wedged into to keep the hub from rotating. Posting a second thread relative to the axle.



'55 Commander
'55 President

Transtar60
03-12-2007, 09:46 PM
Trying picture how the drum came off without the hub.
Did you use a puller(the right one) that pulls on the studs and pushes against the end of the axle??

http://racingstudebakers.com/coppermine/albums/userpics/10056/5E13%20Pic%203.JPG
3E38
4E2
4E28
5E13
7E7
8E7
8E12
8E28
4E2
59 Lark
etc

RHO
03-12-2007, 09:58 PM
Standard type puller with the three grips that are put on a big round ring (it is slotted to allow each one of the trio to be installed) that is threaded onto the big shaft with a point on it that goes into the end of the axle shaft where the 7/8" but was and then the big swing arm you hit the hammer with.
One opposite side the drum came off and the hub fell out of it....I'm used to the drum/hub/lug nut threads staying all together.
We did the opposite first. Then this side and pounded on the hub puller until the drum broke free; then we just pulled it/tapped it with a hammer and thr drum came off and left the hub with the studs there. I took pictures of the puller mounted just on the hub but don't know how to post them. But we did get the hub off.

'55 Commander
'55 President

Transtar60
03-12-2007, 10:39 PM
Ok I understand now , the studs werent swaged anymore, and the drum basically just fell off. Thanks for the followup.

http://racingstudebakers.com/coppermine/albums/userpics/10056/5E13%20Pic%203.JPG
3E38
4E2
4E28
5E13
7E7
8E7
8E12
8E28
4E2
59 Lark
etc

gordr
03-13-2007, 12:13 PM
Sounds like you do need new drums, since the drums are supposed to be swaged to the studs in the hubs. I have a complete power train, including rear axle and brakes, from a '55 President. I'm not currently at home, but I could check in a day or so and see how good the drums are. I'm located in Alberta, but plan to be going to the Portland Swap meet in April, and could bring drums with me, if that would be any help to you. I should have more than one set of 10" rear drums in any case.

Gord Richmond, within Weasel range of the Alberta Badlands

RHO
03-13-2007, 07:37 PM
Gord, I'm way down in the southeast in northern Alabama....would have to ship. Keep me posted. Thanks. I was told today mine were too bad to be turned.

'55 Commander
'55 President

RHO
03-15-2007, 06:53 AM
Confirmed today my rear drums too far gone to turn. Indeed the left rear is so thin you have to be careful not to get cut on it. I have a NOS front drum w/o hub with an original sticker of '54-'64 Studebaker along with 5 different part numbers. What about the rear? Certainly these can't be this hard to find if they are applicable across a decade with all the Hawks, etc.

'55 Commander
'55 President