PDA

View Full Version : Again, with the details...



Mike Van Veghten
03-11-2007, 01:59 PM
I just removed one tie rod from my Conestoga because one of the ends felt worn out.

Well...the pivot details were fine and still tight.

But the way the stud end was threaded is very dangerous.
The die went on at an angle...and starting about 1/3 of the way down to the joint, there was a heavy undercut on one side and no threads on the other side. And because of the mis-machining, the threaded end is also bent...towards the weak end!!!

This car was supposedly restored about 25 years ago by a restoration company. Don't have a clue who it was. Before my ownership time!

Anyway..this is just a warning...check "[u]ALL</u>" of your parts before you install them. If someone installs them for you...check them before they install them.

Mike

N8N
03-11-2007, 07:02 PM
Sounds like someone cross-threaded the castle nut and ran it on with an air gun. It happens... I'd replace the castle nut when replacing the tie rod end, just for insurance. BTW I think it was Bill Cathcart or someone set up next to him that I bought a set of new tie rod boots from; I didn't replace my tie rods when I rebuilt my front end because they felt OK, but having new boots should help keep them usable longer. Which reminds me, I still don't have one of those little press things to remove the tie rods without screwing up the boots (I just used a pickle fork as the boots were destroyed anyway)

nate

--
55 Commander Starlight
http://members.cox.net/njnagel

Mike Van Veghten
03-11-2007, 08:56 PM
With due respect...No sir...

Very nice clean cut threads...once cut!

Beside there is "no" castle nut where the 5/8"-18" thread, threads into the...."tubing"!

Just a tie rod end that didn't get inspected during the manufacturing process.

Manufacturing mistake that can happen to any part...and that can take lives!

Mike