PDA

View Full Version : vacuumadvance



fh929
09-15-2005, 07:58 PM
my 37 dictator runs very rough , when it runs at all.
I have found that the vacuum advance sems to stick. the shaft moves but does not return . is there any way to fix it other than trying to find a new one?[?]

Sonny
09-15-2005, 11:34 PM
quote:Originally posted by fh929

my 37 dictator runs very rough , when it runs at all.
I have found that the vacuum advance sems to stick. the shaft moves but does not return . is there any way to fix it other than trying to find a new one?[?]


I dunno exactly what's wrong with it Frank, but I'd pull it off and take a closer look. You might be able to free it up on the bench better than tryig to get it going in the car. It sounds like the old diaphragm is as hard as chicken lips and it's taken a "set" from sitting idle in the same place for so long. I doubt it would be any good even if you could soften it up a little with a shot or two of silicone spray, (at least that's how MY luck goes :().

Also, I would pull that distributor out and clean it thoroughly, especially around/under the advance plate. Old grease gets real hard, mebbe that would help it, especially if the advance is weak.

There IS somebody rebuilding vacuum advances out in CA somewhere, but I dunno who it is. Good luck and please let us know what ya find.

Sonny
http://RacingStudebakers.com

Stude4x4
09-15-2005, 11:55 PM
The diaphram inside the vaccum advance is probably shot. I have an Avanti distributer on my Champ pickup.(which is dual points) The vaccum advance for the Avanti is no longer available. I ended up fixing the vaccum advance myself. It took some machine work but it wasn't a problem for me because I have a machine shop.
Randy Varozza