PDA

View Full Version : R2 AFB Woes Revisited



wagone
06-14-2005, 10:29 PM
I had asked for advice on this issue about two weeks ago and hopefully someone who reads this will have read my previous sad tale and or someone with advice will offer help now. This may get a little long, but I'll try and be as brief as possible. The original question concerned an R2 AFB, which after a complete rebuild, began peeing (sorry, for the language, but I'm getting a little short of patience) fuel out of the accelerator pump hole at LOW engine speeds. Although not a carb expert, I have some experience and rebuilding carbs is not rocket science. The carb rebuilds I've done in the past have given me no grief and I am a reasonably careful person on such matters. My last item on this forum said that I was going to reset the float level to 7/16" (from the book spec of 3/8") and try that. Well that offered no improvement and in fact resetting the float level back to 3/8" flooded the engine so badly that it wouldn't even start (as it also wouldn't with the float at 7/16"). Remember that it would START before this point in time, but push (for want of a better term) fuel out the pump opening (with an o-ring around the shaft). My original reason for the carb rebuild was to try and correct a fuel starvation (as if the tank were running empty) problem at highway speeds. I elected to do the carb work before investigating a possible tank sediment problem around the tank outlet connection. Not to complicate this too much, but before I tackled the carb I first attempted to get a kit to rebuild the fuel pump (no luck, as no one locally sells pump kits because, they say, of potential liability issues--figure that one?). I had bought a pump rebuild kit from Ted Harbit before he "closed up shop", but it turned out to be for the original R2 pump and will not fit my Chrysler modified pump which was on the car when I bought it (stay with me as I'm about to tie this all together--hopefully). Now jumping forward back to the present, I ordered new needles and seats (also floats) from Summit Racing for the currently available Edelbrock nee Carter AFB. The new floats acted in a pan of water EXACTLY like the originals--so rather than wonder whether the float setting of the new floats needed to be changed from the factory 3/8" I set the new floats aside and installed the second new set of needles and seats (the carb kit with the first set of new needles and seats also came from Harbit). I can now overhaul an AFB in the dead small hours of a moonless night. Back together with the original floats and the Edelbrock needles and seats the engine fired right off--but once around the block and the fuel peeing problem was back. The final note in this "WAR and Peace" type novel is that when (about six weeks ago) I couldn't rebuild the fuel pump which was on the car when I bought it I bought an R2 pump from Ed Reynolds for $176 (yikes!) and it is on the car. So I'm wondering if excessive fuel pump pressure is holding the needles off the seats--so now that the engine will at least start again I can now check the fuel pump pressure of this EXPENSIVE unit. And the answer is..... that the pressure gauge needle, at about 800-1000 engine RPM, swings wildly between 7 and 10 PLUS pounds of pressure (factory is 5 1/2 to 7 pounds). So I'm wanting to blame this pump. I called Federal Mogul (they now handle Carter "stuff") and was told --if you can believe it?-- that they don't make a pump for this application and can't handle warranty issues as a result. Next call to Ed Reynolds, who said, in effect, "sorry, I don't warranty what I sell--tough luck". This pump is a Federal Mogul no. M6270 which, I'm told, is a drag racing pump for small block Chryslers. I now begin to understand why some guys run electric pumps. Any advice out there? What about a WHOPPING 7-10 psi, and wildly fluctuating? This can't be right. This reading is with the pressure line from the s'charger either connected or disconnected--makes no difference to pump pressure. To recap, in sequence, I first put Ed Reynolds' fuel pump on (about six weeks ago), then rebuilt the

Chicken Hawk
06-14-2005, 11:39 PM
[quote]quote:Originally posted by wagone

I had asked for advice on this issue about two weeks ago and hopefully someone who reads this will have read my previous sad tale and or someone with advice will offer help now. This may get a little long, but I'll try and be as brief as possible. The original question concerned an R2 AFB, which after a complete rebuild, began peeing (sorry, for the language, but I'm getting a little short of patience) fuel out of the accelerator pump hole at LOW engine speeds. Although not a carb expert, I have some experience and rebuilding carbs is not rocket science. The carb rebuilds I've done in the past have given me no grief and I am a reasonably careful person on such matters. My last item on this forum said that I was going to reset the float level to 7/16" (from the book spec of 3/8") and try that. Well that offered no improvement and in fact resetting the float level back to 3/8" flooded the engine so badly that it wouldn't even start (as it also wouldn't with the float at 7/16"). Remember that it would START before this point in time, but push (for want of a better term) fuel out the pump opening (with an o-ring around the shaft). My original reason for the carb rebuild was to try and correct a fuel starvation (as if the tank were running empty) problem at highway speeds. I elected to do the carb work before investigating a possible tank sediment problem around the tank outlet connection. Not to complicate this too much, but before I tackled the carb I first attempted to get a kit to rebuild the fuel pump (no luck, as no one locally sells pump kits because, they say, of potential liability issues--figure that one?). I had bought a pump rebuild kit from Ted Harbit before he "closed up shop", but it turned out to be for the original R2 pump and will not fit my Chrysler modified pump which was on the car when I bought it (stay with me as I'm about to tie this all together--hopefully). Now jumping forward back to the present, I ordered new needles and seats (also floats) from Summit Racing for the currently available Edelbrock nee Carter AFB. The new floats acted in a pan of water EXACTLY like the originals--so rather than wonder whether the float setting of the new floats needed to be changed from the factory 3/8" I set the new floats aside and installed the second new set of needles and seats (the carb kit with the first set of new needles and seats also came from Harbit). I can now overhaul an AFB in the dead small hours of a moonless night. Back together with the original floats and the Edelbrock needles and seats the engine fired right off--but once around the block and the fuel peeing problem was back. The final note in this "WAR and Peace" type novel is that when (about six weeks ago) I couldn't rebuild the fuel pump which was on the car when I bought it I bought an R2 pump from Ed Reynolds for $176 (yikes!) and it is on the car. So I'm wondering if excessive fuel pump pressure is holding the needles off the seats--so now that the engine will at least start again I can now check the fuel pump pressure of this EXPENSIVE unit. And the answer is..... that the pressure gauge needle, at about 800-1000 engine RPM, swings wildly between 7 and 10 PLUS pounds of pressure (factory is 5 1/2 to 7 pounds). So I'm wanting to blame this pump. I called Federal Mogul (they now handle Carter "stuff") and was told --if you can believe it?-- that they don't make a pump for this application and can't handle warranty issues as a result. Next call to Ed Reynolds, who said, in effect, "sorry, I don't warranty what I sell--tough luck". This pump is a Federal Mogul no. M6270 which, I'm told, is a drag racing pump for small block Chryslers. I now begin to understand why some guys run electric pumps. Any advice out there? What about a WHOPPING 7-10 psi, and wildly fluctuating? This can't be right. This reading is with the pressure line from the s'charger either c

whacker
06-15-2005, 12:26 AM
Might I suggest a fuel pressure valve between the pump and the carb? With a return line to the tank? They are not real expensive, and could be adjusted for the optimum pressure. I think you would need to have one if you ran an electric pump, and it couldn't hurt with a mechanical pump either.

Mike
06-15-2005, 04:56 AM
I have used the modified Carter M6270 on my R2 with no problems. It's rated at 7.5 to 8 lbs. The M6902 is a street version rated at 6 lbs.
I rebuilt mine using internal parts from a new pump, from Summit, and my modified actuating arm.
Kits to rebuild the Chrysler pump, or the R2 are available from:
http://www.then-now.com/The_Cellar/cellar.htm .
It sounds like your fuel return line may be blocked. It should run from a "T" on the output of the fuel pump to the top of the fuel tank. Make sure it's clear.
The original R2 pump is a Carter 3508S. An R1 pump, 3509S, is idenical except for the boost referance line; and can be modified to use with the supercharger.
Mike M.

studegary
06-15-2005, 03:48 PM
My net to this is to install a fuel pressure regulator and adjust it for 6 psi. Also, make sure that your return line is working properly.

Alan
06-15-2005, 04:03 PM
I had the same problem on one supercharged motor a few years back I used a Summit regulator SUM-G3131 34.95 but you have to modify it with a pressure compensating port for Supercharger reference. But you can try it first without if you don't get on the boost to hard.

Dan White
06-16-2005, 03:26 PM
Doesn't Dave Thibeault rebuild AFBs for Supercharged Studes? I have always heard he was pretty good at these things, maybe giving him a call would help?

Dan White
64 R1 GT
64 R2 GT

N8N
06-16-2005, 04:23 PM
If you have a fuel pump with eight screws I believe that is an old replacement pump, not the original pump (or I may have my facts backwards...) anyway if you call up Phil Harris and tell him what you have he ought to be able to hook you up with a rebuild kit. I think last time I spoke to Ted H. about rebuilding these pumps (I did about 4 or 5 at one shot a year ago or so) he specifically asked about the number of screws so I assume that meant he had both kits in stock.

I second the suggestion to check your return line before condemning the pump... but it's still possible that the pump is putting out too much pressure.

good luck,

nate

--
55 Commander Starlight
62 Daytona hardtop
http://home.comcast.net/~njnagel