PDA

View Full Version : Heater control valve



John Ratliff
01-29-2007, 12:57 AM
The heater valve on my Hawk does not seem to close. The cable works okay and the valve lever goes in and out okay but does not shut off. The repair book says not to repair but replace. I can't find them listed in any catalog for '56. Has any one repaired one and where did you get the parts?[?]
Also what kind of seal is used around the in and out lines on the heater core under the seat? Mine just comes through the floor and has space around the lines. Looks like some type of gasket should go there.[xx(]

John Ratliff
http://static.flickr.com/102/302372902_63249ab71a_m.jpg

Roscomacaw
01-29-2007, 03:12 PM
It's been awhile since I took one of those valves apart. If you're talking about the Ranco valve on the firewall, you can get a repair kit from NAPA to fix those. It's actually kinda laughable because this "kit" consists of ONE rubber valve diaphragm and that's it! Was $16 bucks last time I bought one. SI has rebuilt valves for $85 exchange (part# 532880)

As to the heater hoses, there were little die-cut pieces of foam rubber that sealed off those holes. You could easily fudge something workable yourself.;)

Miscreant adrift in
the BerStuda Triangle
http://images.andale.com/f2/115/106/906179/2006/12/7/truckonhill3.jpg

1957 Transtar 1/2ton
1960 Larkvertible V8
1958 Provincial wagon
1953 Commander coupe

rockne10
01-29-2007, 10:25 PM
SI sells the foam seals, part #519409 for $2 each but sage advice cannot be discounted.

Brad Johnson
Pine Grove Mills, Pa.
33 Rockne 10
51 commander Starlight
53 Commander Starlight
http://i57.photobucket.com/albums/g233/rockne10/ddc714b7.jpg

John Ratliff
01-30-2007, 01:25 AM
Thanks, for the info. Think I will try and repair the one I have since it is not frozen. If it doesn't work then I see about the $85.00 lay out. ;)
Will let you know how it turns out.

John Ratliff
http://static.flickr.com/102/302372902_63249ab71a_m.jpg

Tom B
01-30-2007, 07:13 AM
I rebuilt one recently, The little rubber gismo cost me $12 and change.
I don't know about "wont shut off," the repair is for "Leaks."

It's not a repair I'd want to tackle with a hangover, but it was interesting.

If you're serious about it email me for details.

[img=left]http://www.alink.com/personal/tbredehoft/Bothcars.jpg[/img=left]
Tom Bredehoft
'53 Commander Coupe
'60 Lark VI
'05 Legacy Ltd Wagon
All three Indiana built OD cars

Blue 15G
01-30-2007, 07:32 AM
Or if you're not worried about originality and just want something that works for much less than $85, go to your local FLAPS and get a universal heater control valve with a sliding lever that hooks right to your cable. Put one on my '54 about 10 years ago and it works great. There was some minor plumbing involved. I think mine was fron a late '70s Dodge pickup.

John Ratliff
01-30-2007, 11:51 PM
Tom, got your e-mail and printed copies. If this doesn't help me then there is no hope.[:o)] Man, this club sure has some great teachers.[^]
Thanks

John Ratliff
http://static.flickr.com/102/302372902_63249ab71a_m.jpg