PDA

View Full Version : Power Steering question



S_Ferrell
11-25-2006, 09:40 AM
Hello, earlier this fall, I got tired of throwing PS fluid into Stuart, my 1962 Cruiser. I had the belt taken off until I can afford to get a new pump. My question, will driving a PS car with no PS car hurt it? It feels that I do not have the kind of control that I use to have. I am getting ready to put him down for his winter nap, but I was wondering about next spring. Thanks.

N8N
11-25-2006, 09:56 AM
It won't hurt the car, but you will have more play in the steering with the control valve not pressurized. Hopefully someone has a good used PS pump for you.

nate

--
55 Commander Starlight
http://home.comcast.net/~njnagel

S_Ferrell
11-25-2006, 10:00 AM
Thank you, for a moment, I thought the front end was going out of aligment.

Skip Lackie
11-25-2006, 10:03 AM
Without the P/S pump connected, the system is no longer pressurized, and there is more "slop" in the steering. The steering wheel is still connected to the steering linkage via the P/S control valve, which is no longer doing its job. And the P/S cylinder (which normally provides the push to help turn the wheels) is still there, too, and is now actually hurting instead of helping. If the only reason for disconnecting the power steering was because it was leaking, you might want to consider repairing the leak. Could you tell where the fluid was leaking from? Rebuild kits for all three major components (pump, control valve, and cylinder) are available and are relatively inexpensive, and completely rebuilt units are around as well. The leak might even be from a hose, which would be cheap to fix.

Your car could be converted back to non-power steering, but it would require access to a parts car and would probably cost more in the long run than repairing your current system.

Skip Lackie

S_Ferrell
11-25-2006, 10:56 AM
The hoses were replaced over the summer, they lasted one month and started to leak again. I took it to the museum and found that it is the pump. I will only drive the car once more to the gas station to fill it for its nap. Hopefully by May 2007, I will be able to afford a new kit.

Mike
11-26-2006, 05:35 AM
Where did the hoses start to leak?
Most people don't realize that the seats the flared tubing seals against, in the control valve, are replicable. They are soft aluminum; and easily damaged. There's a relief valve under one of them that should be cleaned in a thorough rebuild.
Does anyone know where to get the darned things? There are three sizes on the control valve and ram. They may be a fairly standard hardware item.
Mike M.

S_Ferrell
11-26-2006, 01:15 PM
The hoses I replaced were the orginal hoses. The new ones worked well for one month, and I started to throw fluid again. Since I was not working and wanted to drive the car, I had my man take the belt off. As I said, the car will take its nap and with my new job, I hope that I will be able to replace the entire unit replaced along with thr trunck lock. Whois good ay trunk locks?

Skip Lackie
11-27-2006, 02:05 PM
quote:Originally posted by S_Ferrell

The hoses I replaced were the orginal hoses. The new ones worked well for one month, and I started to throw fluid again. Since I was not working and wanted to drive the car, I had my man take the belt off. As I said, the car will take its nap and with my new job, I hope that I will be able to replace the entire unit replaced along with thr trunck lock. Whois good ay trunk locks?


The question that Mike is asking is: "Is the hose(s) leaking from the hose itself, or from where it attaches to the pump or the control valve?". If the hose itself is leaking, then you need to replace the hose. If it's leaking from one of the fittings, then it's possible that it just needs to be tightened, or maybe the seat in the control valve or pump is worn out. In other words, there are two possible diagnoses, and they have different solutions.

Skip Lackie

S_Ferrell
11-29-2006, 04:44 PM
Hi. The hoses are in good shape, it is leaking from the where the return hose is connected to the pump.

Skip Lackie
11-29-2006, 06:42 PM
quote:Originally posted by S_Ferrell

Hi. The hoses are in good shape, it is leaking from the where the return hose is connected to the pump.


You might want to check to see if that fitting is tight enough. It might just need to be tightened another 1/8 of a turn or so.

Skip Lackie