PDA

View Full Version : Brakes: Power brakes not releasing.



jostanton1
10-30-2018, 11:14 AM
My 64 Hawk has disc brakes with a rebuilt Hydrovac. After applying and then releasing, the brakes still hold for about 10 seconds before fully releasing. Is this an issue with the Hydrovac? I also installed a new master cylinder specific to disc brakes. Is it a check valve issue perhaps?

StudeRich
10-30-2018, 04:37 PM
The Number ONE suspect for these issues is always those pesky 2 short Flex Hoses at the Hydrovac.
They swell up internally and get Kinked, so if they are not really Fresh, you might want to replace them.

As long as your New Master Cylinder has had the Residual Valve removed from the end of the return spring and the rubber cushion in the end of the Cylinder used for Drum Brakes, THAT Should not be your problem.

The vacuum Check Valve in the Hose from the intake Manifold is just a one-way valve to hold the Vacuum only in the Hydrovac, I don't see that as a problem either.

There are no troublesome Equalizer Valves in a stock Studebaker Disc Brake setup.

How about the pedal RETURN, is the return spring and Pedal adjustment allowing a full, rapid, Pedal Return with some free play at the Top of travel?

ColoradoHawk
10-31-2018, 02:24 AM
My ‘63 GT with disc brakes had the same problem with a rebuilt Hydrovac too recently. If I would give the brake pedal a quick “stab” the brakes would release. Issue turned out, for me, that a seal inside the unit failed allowing brake fluid to be sucked in to the engine. As soon as I got a replacement unit my problem was gone. Check the vacuum line going to your unit and see if there is any brake fluid there, mine was coming out in a steady drip.

jostanton1
10-31-2018, 05:11 PM
Thanks guys. I have new short lines to the Hydrovac, so I am going to pull apart the master and check to see if I forgot to remove the Residual Valve. And go from there.

jostanton1
11-02-2018, 08:25 PM
The Residual Valve was in the master cylinder and I removed it. I bled the system and the brakes are still not releasing quickly. They still hesitate for a few seconds. I've had 2 disc brake cars with Hydrovacs in the past and never experienced this issue.