PDA

View Full Version : Fuel System: Need some help with a BBR1 Carter carb setup on my 2R5



cavanbound
11-11-2017, 11:54 AM
I have limited experience doing anything but basic troubleshooting of carbs, but decided to pull and rebuild the Carter BBR1 on my 2R5, after a chronic flooding problem developed. It was probably just float adjustment, but I decided to do the full rebuild anyway.

After rebuild, I've got a few related problems. Though the flooding is addressed and the engine now fires with choke, the carburetor throttle lever (attached to the extended foot pedal armature) is obviously adjusted incorrectly, as the engine revs to full throttle immediately after firing. I've shut it down twice immediately now, and have the top off the carb again. I think I may have goofed up the exterior throttle lever assembly - I can't find a reference photo showing the angle at which this should be setup. Also, I've got some problem with how the accelerator pump is setup - there is a notch half-way down the flat shaft, and it seems logical that this should be where the arm engages that shaft - but the only good reference I found (Mike's carburetors - tear-down and reassembly video on YouTube) was a bit unclear on this.

I've shot a quick video clip of how mine is setup: https://youtu.be/MCfXtHObCOY. Also, a few reference photos below. Can anyone point me in the right direction?

68447 68448

jackb
11-11-2017, 12:00 PM
What is maybe happening to yours, which is happening to mine, is that the lever (with the 2 rod holes), is rotating around the throttle shaft. It is a "pinch" fitment to adjust the accelerator rod to throttle shaft. After some use (60+ years) the pinch doesn't want to pinch anymore due to ground down condition. Especially doesn't like kickdown activity. I have to adjust mine every month or so....

cavanbound
11-11-2017, 12:07 PM
I think that's part of my problem - I loosened that unnecessarily during the rebuild, and now am unsure how it should be positioned - any orientation I work with seems to produce some "catch" in the pedal travel. Jackb, can you tell from my video if my accelerator pump setup is correct? Thanks for the quick response.

StudeRich
11-12-2017, 01:10 AM
Are you SURE that Carb. is a Studebaker BBR1? I have them here and have seen many and NONE look anything like that one. :confused:

cavanbound
11-12-2017, 07:42 AM
StudeRich - yes, pretty certain. It's stamped on the side of the float bowl, and everything else about the carb lines up as expected. I relied quite a bit on Mike's Carburetor assembly video on YouTube (https://www.youtube.com/watch?v=Qg19Cz2dWAI), and that also lines up very well - it's exactly the same unit - I just can't tell if I've got the accelerator pump set up correctly. Thanks.

jackb
11-12-2017, 08:16 AM
What I have done with mine is to loosen the pinch screw. Rotate the lever up (vertical) and towards the engine until you have the least amount of shearing force through the carb shaft (horizontally), but enough so that the rod will pull effectively. I have had to graft some JB Weld to the fast idle cam (due to similar wear factor) to get a decent warm up speed. As a matter of fact, outside today to start my truck was 20 degrees and I still don't have enough cam buildup to get the right fast idle speed for cold warmup....

Mrs K Corbin
11-13-2017, 06:43 AM
There were at least 2 BBR1's, one for Chrysler and one for Studebaker that I know of. both use the same kit, but they are not identical internally. Ever notice there are leftover gaskets in that kit?

What jackb said is probably your best bet. I've been known to take a Looong screwdriver and just stick it down thru the carb to open the butterfly while cranking, but this limits your travel and should only be temporary enough to see if it starts that way.

cavanbound
11-13-2017, 07:47 PM
Thanks for the pointers...I'll report back when I've got enough garage time this week to get back to this. Did anyone have a chance to take a peek at the YouTube clip to offer an opinion on whether I have the accelerator pump shaft/spring setup correctly?