PDA

View Full Version : Fuel System: Think tank time.........



Hawklover
08-21-2017, 02:14 PM
My R-1 Avanti idles like a fine Swiss watch.......spot on!

But after a run on the expressway when she is hot she idles way below 650 rpm and I have to keep "goosing" the gas (4-sp) to prevent stalling.

Do not want to kick up the idle when cold, to compensate.

Any ideas wheat causes the car to drop a good steady idle after a hot run and then off ramp in city traffic??

Thanks in advance:-)

thunderations
08-21-2017, 03:06 PM
I'd check the choke and the fast idle adjustment. Your choke may be adjusted to rich, keeping the fast idle plate from going to standard idle until the engine gets way up on the operating temp.
When you first start the car, check to see if the idle adjustment screw is touching the tab or is it held away? It should be away just a little. Let the car run for awhile and when the temp gauge says it's at operating temp, tap the throttle and then check that setting again. The adjusting screw should now be touching the tab. If not, something is out of adjustment or binding, not allowing the fast idle cam to rotate and give you operating temp idle speed.
Another way is to adjust the idle to where you want it after this hot expressway run. Then the next time you start it cold, see if it idles to fast.

PackardV8
08-21-2017, 04:03 PM
Check the integrity of the intake manifold gaskets and hold-down bolts. It's not unusual for the gaskets to burn out and/or the bolts to loosen and/or the hold-down clamps to crack. When warm, the cracks open more.

jack vines

Hawklover
08-21-2017, 05:22 PM
The car has a AFB clone carb by Edelbrock with electric choke, and no dash pot.
I'd check the choke and the fast idle adjustment. Your choke may be adjusted to rich, keeping the fast idle plate from going to standard idle until the engine gets way up on the operating temp.
When you first start the car, check to see if the idle adjustment screw is touching the tab or is it held away? It should be away just a little. Let the car run for awhile and when the temp gauge says it's at operating temp, tap the throttle and then check that setting again. The adjusting screw should now be touching the tab. If not, something is out of adjustment or binding, not allowing the fast idle cam to rotate and give you operating temp idle speed.
Another way is to adjust the idle to where you want it after this hot expressway run. Then the next time you start it cold, see if it idles to fast.

paintim613
08-21-2017, 05:23 PM
Mine was doing the same thing and the problem was the vacuum advance.

thunderations
08-21-2017, 08:14 PM
That carb still has a rich and lean adjustment on the choke that adjusts the fast idle cam. I have the same carb on my 66 Daytona and 57 Thunderbird.

The car has a AFB clone carb by Edelbrock with electric choke, and no dash pot.

WCP
08-21-2017, 09:35 PM
Check the hot idle compensator valve in the secondary bores. It probably is closed off and not opening when the engine is hot.

Hawklover
08-21-2017, 10:26 PM
In an Edelbrock???????
Check the hot idle compensator valve in the secondary bores. It probably is closed off and not opening when the engine is hot.

WCP
08-22-2017, 11:02 AM
You might have indicated that in your first post and then I wouldn't have wasted my time!

jif988
08-24-2017, 10:47 AM
I had the same problem with my Avanti R-2...not wanting to idle on a hot day and after a hot run on expressway, etc. I solved it by blocking off the exhaust ports in the intake manifold by filling them with balled up aluminum foil and then sealing them in with furnace cement. Also got rid of the heat riser valve that is between the right side exhaust pipe and the exhaust manifold. The above measures serve to reduce overheating of the manifold and carburetor, these things will make the carb run cooler. Your problem is most likely fuel boiling in the carb and the result is an overly rich mixture which will not allow the car to idle smoothly. To do the above modifications, of course, you need to remove the intake manifold to block off the exhaust passages and also when removing the heat riser valve you should replace it with a spacer to keep the same geometry of the exhaust pipes. The spacer is available, I think, from Jon Meyer Studebaker and he can also give you additional tips to keep your carb running cooler...good luck...Lance

Hawklover
08-24-2017, 08:11 PM
I removed the heat riser valve and replaced it with on open spacer. Under the carb I put an extra steel and composition gasket to keep heat off the base of the carb. Now in the winter (if no snow) I will use the car every now and then.....and this situation is non-exisistant, meaning after a highway run and into stop and go traffic I have no idle problems.
I had the same problem with my Avanti R-2...not wanting to idle on a hot day and after a hot run on expressway, etc. I solved it by blocking off the exhaust ports in the intake manifold by filling them with balled up aluminum foil and then sealing them in with furnace cement. Also got rid of the heat riser valve that is between the right side exhaust pipe and the exhaust manifold. The above measures serve to reduce overheating of the manifold and carburetor, these things will make the carb run cooler. Your problem is most likely fuel boiling in the carb and the result is an overly rich mixture which will not allow the car to idle smoothly. To do the above modifications, of course, you need to remove the intake manifold to block off the exhaust passages and also when removing the heat riser valve you should replace it with a spacer to keep the same geometry of the exhaust pipes. The spacer is available, I think, from Jon Meyer Studebaker and he can also give you additional tips to keep your carb running cooler...good luck...Lance

Hawklover
08-24-2017, 08:13 PM
I did.......read post number 4!
You might have indicated that in your first post and then I wouldn't have wasted my time!